Question Vlan Implemetation on 3750 Stack

Answered Question
Dec 7th, 2007

I have a 3750 stack which is my core switch that all servers are connected too. I have 8 Vlans that I have created on the core switch and 9 edge switches that I have created the vlans on too. I haven't added the uplink ports to the core switch to the Vlans yet. My questions how I setup the ports on the core switch for so that all users will have access to the different servers on the core switch.

I have this problem too.
0 votes
Correct Answer by Jon Marshall about 9 years 1 month ago

If you are using the ip-helper function then you must have a DHCP server with the scopes on it. Just make sure that for each scope you set the correct default-gateway

ie.

vlan 50 = 192.168.50.1

vlan 60 = 192.168.60.1

vlan 70 = 192.168.70.1

vlan 80 = 192.168.80.1

and obviously exclude the .1 address from each subnet from the scope.

Jon

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Jon Marshall Fri, 12/07/2007 - 07:37

Hi

it depends on how the vlans are spread across your edge switches. If each edge switch has a mixture of the 8 vlans on it then you need to confgure the uplink ports as trunk ports on the edge switch end and the 3750 end.

If it one vlan per edge switch you can configure the uplinks connections as access ports and make sure they are both in the same vlan as is on the edge switch.

You will also probably need to have L3 SVI's on the 3750 for the vlans if you want to do inter-vlan routing eg.

interface vlan10

ip address 192.168.5.1 255.255.255.0

no shut

interface vlan 20

ip address 192.168.10.1 255.255.255.0

no shut

etc...

If you are using trunks from the edge switches to the 3750 you could also consider using VTP which allows you to create a new vlan on one switch, in your case probably the 3750, and this vlan then gets added to all the edge switches.

HTH

Jon

keyyo0200 Fri, 12/07/2007 - 07:44

Thanks, for the info. What about the ports that the different servers are connected to on the 3750 stack. I have a mail server, AS400 and storage servers connected to the 3750 stack and need to have multiple users access these server so do I setup the ports as trunks to accept multiple vlans.

Jon Marshall Fri, 12/07/2007 - 07:47

No you don't need to because your L3 SVI's will do the routing between vlans ie.

client vlan 10 = 192.168.5.0/24

client vlan 20 = 192.168.6.0/24

server vlan 30 - 192.168.10.0/24

On your 3750 you would have

interface vlan 10

ip address 192.168.5.1 255.255.255.0

interface vlan 20

ip address 192.168.6.1

interface vlan 30

ip address 192.168.30.1

clients in vlan 10 set their default-gateway to 192.168.5.1

vlan 20 clients default-gateway 192.168.6.1

All your servers would have 192.168.10.1 as default-gateway.

The 3750 will then route between the vlans

HTH

Jon

keyyo0200 Fri, 12/07/2007 - 08:07

Here is a sample that I have created. I have created the vlans with IP helper address for on the 3750 stack for the Vlans.

Example

interface Vlan50 server

ip address 192.168.50.1 255.255.255.0

ip helper-address 192.168.88.2

!

interface Vlan60 client

ip address 192.168.60.1 255.255.255.0

ip helper-address 192.168.88.2

!

interface Vlan70 client

ip address 192.168.70.1 255.255.255.0

ip helper-address 192.168.88.2

!

interface Vlan80 client

ip address 192.168.80.1 255.255.255.0

ip helper-address 192.168.88.2

I have a static route on the router that points the vlan address to the core switch.

Example

ip route 192.168.50.0 255.255.255.0 192.168.99.3

ip route 192.168.60.0 255.255.255.0 192.168.99.3

ip route 192.168.70.0 255.255.255.0 192.168.99.3

ip route 192.168.80.0 255.255.255.0 192.168.99.3

Please clear my confusion

Thanks

Jon Marshall Fri, 12/07/2007 - 08:10

Sorry, i'm confused now. From your original post i thought the 3750 was you core switch ?

What is 192.168.99.3 ?

Jon

Jon Marshall Fri, 12/07/2007 - 08:45

Okay, so what is your confusion in your previous post then. Is the config not working ??

Jon

keyyo0200 Fri, 12/07/2007 - 08:48

Could you clear up the default gateway question up for me if I am using the example config for the vlans and DHCP.

Thanks

Correct Answer
Jon Marshall Fri, 12/07/2007 - 08:52

If you are using the ip-helper function then you must have a DHCP server with the scopes on it. Just make sure that for each scope you set the correct default-gateway

ie.

vlan 50 = 192.168.50.1

vlan 60 = 192.168.60.1

vlan 70 = 192.168.70.1

vlan 80 = 192.168.80.1

and obviously exclude the .1 address from each subnet from the scope.

Jon

keyyo0200 Fri, 12/07/2007 - 08:54

Thanks for clearing this up for me, you have been very helpful

Actions

This Discussion