Can interface port-channel run concurrently both L2 & L3.

Unanswered Question
Dec 7th, 2007
User Badges:

MY team is doing migration at remote site. They have similar two C6509 connected back via fiber.


Before migration below is the command in Core 1;

!

interface GigabitEthernet8/1

description to-Core2-L3PortChannel1-link1

no ip address

mls qos trust dscp

carrier-delay msec 0

channel-group 1 mode active

!

interface GigabitEthernet8/2

description to-Core 2-L3PortChannel1-link2

no ip address

mls qos trust dscp

carrier-delay msec 0

channel-group 1 mode active

!

interface GigabitEthernet9/1

description to-Core2-L3PortChannel1-link3

no ip address

mls qos trust dscp

carrier-delay msec 0

channel-group 1 mode active

!

interface GigabitEthernet9/2

description to-Core2-L3PortChannel1-link4

no ip address

mls qos trust dscp

carrier-delay msec 0

channel-group 1 mode active

!

interface Port-channel1

mls qos trust dscp

dampening

!

interface Port-channel1.900

description to-ABF608.DC.GR.CR65.2-Area0

encapsulation dot1q 900

ip address 10.62.247.213 255.255.255.252

ip ospf network point-to-point

!

interface Port-channel1.901

description to-ABF608.DC.GR.CR65.2-Area332

encapsulation dot1q 901

ip address 10.41.125.249 255.255.255.252

ip ospf network point-to-point

!

When tried to configure a VLAN eg. 998 and configure int port-channel vlan 998 as below;


interface Port-channel1.998

description Migration VLAN

encapsulation dot1q 998


The question is we can't key in the encapsulation dot1q 998 and the switches comment that it's already existed.


Is there other command that might have left out or the int port-channel just support L3 subinterface only and not L2 subinteface.




  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
r.hew Mon, 12/10/2007 - 00:39
User Badges:

Thanks for your prompt reply.


I did tried it personally in the lab and I got the following message;

PTT351.T01.08.DC.ED6(config-subif)#enc dot1Q 998

Command rejected: VLAN 998 not available


Below cmd the complete "sh run" that I get my remote engineer to send to me;

!

vlan 998

name Migration-VLAN

!

!

interface Port-channel1

dampening

mtu 9216

no ip address

mls qos trust dscp

!

interface Port-channel1.900

description to-ABF608.DC.GR.CR65.2-Area0

encapsulation dot1Q 900

ip address 10.62.247.213 255.255.255.252

ip ospf network point-to-point

!

interface Port-channel1.901

description to-ABF608.DC.GR.CR65.2-Area332

encapsulation dot1Q 901

ip address 10.41.125.249 255.255.255.252

ip pim sparse-mode

ip ospf network point-to-point

!

!

interface GigabitEthernet8/1

description to-ABF608.DC.GR.CR65.2-L3PortChannel1-link1

mtu 9216

no ip address

carrier-delay msec 0

wrr-queue cos-map 1 1 1

wrr-queue cos-map 2 1 0

wrr-queue cos-map 3 1 4

wrr-queue cos-map 3 2 2

wrr-queue cos-map 3 3 3

wrr-queue cos-map 3 4 6

wrr-queue cos-map 3 5 7

mls qos trust dscp

channel-group 1 mode active

!

interface GigabitEthernet8/2

description to-ABF608.DC.GR.CR65.2-L3PortChannel1-link2

mtu 9216

no ip address

carrier-delay msec 0

wrr-queue cos-map 1 1 1

wrr-queue cos-map 2 1 0

wrr-queue cos-map 3 1 4

wrr-queue cos-map 3 2 2

wrr-queue cos-map 3 3 3

wrr-queue cos-map 3 4 6

wrr-queue cos-map 3 5 7

mls qos trust dscp

channel-group 1 mode active

!

interface GigabitEthernet9/1

description to-ABF608.DC.GR.CR65.2-L3PortChannel1-link3

mtu 9216

no ip address

carrier-delay msec 0

wrr-queue cos-map 1 1 1

wrr-queue cos-map 2 1 0

wrr-queue cos-map 3 1 4

wrr-queue cos-map 3 2 2

wrr-queue cos-map 3 3 3

wrr-queue cos-map 3 4 6

wrr-queue cos-map 3 5 7

mls qos trust dscp

channel-group 1 mode active

!

interface GigabitEthernet9/2

description to-ABF608.DC.GR.CR65.2-L3PortChannel1-link4

mtu 9216

no ip address

carrier-delay msec 0

wrr-queue cos-map 1 1 1

wrr-queue cos-map 2 1 0

wrr-queue cos-map 3 1 4

wrr-queue cos-map 3 2 2

wrr-queue cos-map 3 3 3

wrr-queue cos-map 3 4 6

wrr-queue cos-map 3 5 7

mls qos trust dscp

channel-group 1 mode active

!


For your information, there is no int vlan 998 created yet.


So I believed, the port channel can only have either L2 or L3 and can't support both together.


Thanks.

Raymond

Actions

This Discussion