Configuring A Trunk on 2950

Unanswered Question
Dec 8th, 2007
User Badges:

I have two 2950 switches. I am trying to set up a trunk over fa0/1 on both switches. There are no lights on the ports when I connect a cross-over cable. Any suggestions would help. I used the following commands on my first switch (Texas):

en

config t

int fa0/1

switchport mode trunk

speed 100

duplex full

-------------

switch two (Arkansas)

en

config t

int fa0/1

switchport mode dynamic

speed 100

duplex full

----------

Texas#show int fa0/1 switchport

Name: Fa0/1

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: down

Administrative Trunking Encapsulation: dot1q

Negotiation of Trunking: On

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 1 (default)

Trunking VLANs Enabled: ALL

Pruning VLANs Enabled: 2-1001

Protected: false

Voice VLAN: none (Inactive)

Appliance trust: none

-------------

Arkansas#show int fa0/1 switchport

Name: Fa0/1

Switchport: Enabled

Administrative Mode: dynamic desirable

Operational Mode: down

Administrative Trunking Encapsulation: dot1q

Negotiation of Trunking: On

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 1 (default)

Trunking VLANs Enabled: ALL

Pruning VLANs Enabled: 2-1001

Protected: false

Voice VLAN: none (Inactive)

Appliance trust: none

------------------------

Arkansas#sho int fa0/1 trunk

Port Mode Encapsulation Status Native vlan

Fa0/1 desirable 802.1q not-trunking 1

----------------

Texas#show int fa0/1 trunk


Port Mode Encapsulation Status Native vlan

Fa0/1 on 802.1q not-trunking 1



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
glen.grant Sat, 12/08/2007 - 17:00
User Badges:
  • Purple, 4500 points or more

You can't have one side forced on (switchport mode trunk) and the other side "switchport mode dynamic desirable . Just make both sides " switchport mode dynamic desirable" which is the default setting anyway on these switches . If its truly a Xover cable and the ports are administratively enabled then you should get a link light otherwise check or replace the cable. These switches do not have mdix so you must use a xover .

Jon Marshall Sun, 12/09/2007 - 01:10
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Hi Glen


You can have "switchport mode trunk" on one side and "switchport mode dynamic desirable" on the other side and it will form a trunk because DTP will negotiate a trunk. If you look at the output of both interfaces and it says


Negotiation of Trunking: On


If you had


switchport mode trunk

switchport nonegotiate


then yes it would not work.


Jon


ccbootcamp Sat, 12/08/2007 - 20:46
User Badges:
  • Gold, 750 points or more

use a crossover cable, and set both ports to:


switchport mode trunk


that should work for you.


-brad

www.ccbootcamp.com

(please rate the post if this helps!)


dan.cicioiu Sun, 12/09/2007 - 02:20
User Badges:

Hi


could you check the both ports being "no shut".

As you can see on both ports you have "Operational Mode: down". This could be because of the cable or because one or both ports are in shutdown state.



glen.grant Sun, 12/09/2007 - 05:05
User Badges:
  • Purple, 4500 points or more

John is correct about using "on" , though most cisco docs I have seen recomend using desirable - desirable on each end . I have seen problems where trunks are forced on and one end says its trunking and the trunk is not actually working .

ccbootcamp Sun, 12/09/2007 - 06:20
User Badges:
  • Gold, 750 points or more

glen,


yeah, i see the d/d config on a lot of cisco website configs as well.


where have you run into a problem? What type of switches? IOS? or CatOS? i'll lab it up and post the debugs.


i've been setting my 2950 trunks to "trunk" instead of desirable and havent had an issue. i know there used to be an issue (years ago) with doing trunk/trunk on older CatOS switches, but I haven't run into that in a long time.


-brad

www.ccbootcamp.com

(please rate the post if this helps!)

littlegiglow Sun, 12/09/2007 - 10:38
User Badges:

Thanks for everyone's response. It turns out the cable was the problem. It was not a Xcable as advertised.


Thanks

Actions

This Discussion