Setting up a trunk over two 2950s

Unanswered Question
Dec 8th, 2007
User Badges:

I have two 2950 switches. I am trying to set up a trunk over fa0/1 on both switches. There are no lights on the ports when I connect a cross-over cable. Any suggestions would help. I used the following commands on my first switch (Texas):

en

config t

int fa0/1

switchport mode trunk

speed 100

duplex full

-------------

switch two (Arkansas)

en

config t

int fa0/1

switchport mode dynamic

speed 100

duplex full

----------

Texas#show int fa0/1 switchport

Name: Fa0/1

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: down

Administrative Trunking Encapsulation: dot1q

Negotiation of Trunking: On

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 1 (default)

Trunking VLANs Enabled: ALL

Pruning VLANs Enabled: 2-1001

Protected: false

Voice VLAN: none (Inactive)

Appliance trust: none

-------------

Arkansas#show int fa0/1 switchport

Name: Fa0/1

Switchport: Enabled

Administrative Mode: dynamic desirable

Operational Mode: down

Administrative Trunking Encapsulation: dot1q

Negotiation of Trunking: On

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 1 (default)

Trunking VLANs Enabled: ALL

Pruning VLANs Enabled: 2-1001

Protected: false

Voice VLAN: none (Inactive)

Appliance trust: none

------------------------

Arkansas#sho int fa0/1 trunk

Port Mode Encapsulation Status Native vlan

Fa0/1 desirable 802.1q not-trunking 1

----------------

Texas#show int fa0/1 trunk


Port Mode Encapsulation Status Native vlan

Fa0/1 on 802.1q not-trunking 1


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
MUHAMMAD SHAHEEN Sat, 12/08/2007 - 17:01
User Badges:
  • Silver, 250 points or more

Hi,


On your Switch2


Change the configuration to Switchport mode trunk like you did in Switch1 so your Switch2 will have this config


switch two (Arkansas)

en

config t

int fa0/1

switchport mode trunk

speed 100

duplex full


connect both switches Fa 0/1 with cross-over and you should see the trunk link comeup green.


Hope This Helps

Shaheen


glen.grant Sat, 12/08/2007 - 17:30
User Badges:
  • Purple, 4500 points or more

Make both ports "switchport mode dynamic desirable" and let the switch negotiate the trunk this way you will know that the trunk is working correctly.

craig.eyre Thu, 12/13/2007 - 11:22
User Badges:

Hi,


Did you get this figured out?


What version of IOS are you running?


Craig

Actions

This Discussion