Configure user Access verification for remote access (telnet)

Unanswered Question
Dec 11th, 2007

dear all,

i have the cisco 826 ADSL router (firmware 12.2) and want to configure as for use by two users.

Thus i want to have two usernames user1 & user2 for remote access via telnet.

If one of them telnets : he will the get the "user authentication prompt" : username \ password before entering the router> mode.

i use the : username user1 password xxxxx

but with this line only, it does not work. I try to use aaa local also, but i don't really know how to configure it.

Else if authentication mechanism is set, is the mechanism for traditionnal telnet (set by line vty 0 4 + login + password) turned off ?

Thx for helping

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
JORGE RODRIGUEZ Tue, 12/11/2007 - 14:43

Try with this syntax.. do you want to have the user admin access to router?

username JOE1 privilege 5 password XXXXX Level 5 will not have access to configuration or to change anything on outer, it can view interfaces stats etc. If you change to level 15 that will provide admin configuration access.

when telneting they will be prompted with

username:

HTH

Jorge

rate helpful posts!

farellfolly Sat, 12/15/2007 - 04:08

I try the command but it seems not to work.

when i get the "username" prompt, i enter the appropriate username i created , then it displays the "password" prompt and here is the miracle : whatever password i put (enable password, telnet password, or the local user password), it does not work : display is "login invalid".

And if instead of putting the appropriate username, i enter an username which does not exists, it displays automatically "login invalid". That means that in the first case, the username has been recognized, not the pass

Attached is my config ...

I have a question.. i found in the line vty configuration mode that there is such a command "login local" what does it mean, can it help ?

Attachment: 
JORGE RODRIGUEZ Sat, 12/15/2007 - 06:31

Did you try the syntax I posted?

you have :

username Farell password xxxxxx

username Admin password xxxxx

try this :

username Farell privilege 5 password xxxx

username Admin privilege 15 password xxxx

if this don't work , place question mark after "username admin ? , and see what options are available "privilege" should be here.

"login local" means instructing router to check local users password instead of checking on a tacacs server.

Rgds

Jorge

farellfolly Sat, 12/15/2007 - 14:54

After i sen you the post, i've tried :

username Farell password xxxx privilege 5

username Admin password xxxx privilege 15

I think it does not matter the order in which the commands are issued. However i 'll test and tell you back.

Else when i type username Farell + "?"

i see all the available options = line, level, privilege, password...

And when i type username Farell password xxxxx + ? i see the other options, so for me, it did mean my syntax was correct.

I'll tell you tomorow..., thx for helping

Actions

This Discussion