VNC and RDP problems with 1800W

Unanswered Question
Dec 11th, 2007

I have two 1800W routers, one in the main office the other at the secondary office. If I VNC or RDP from a PC in the main office to a PC in the secondary through the GRE tunnel I do not see the other screen, the mouse moves okay but no picture. If however, I do the same from the secondary office to the main office it works fine. I have tried changing the access-list, the NAT, everything, but nothing seems to work.

I have the original network still going. It consists of (main) a 2600 and secondary a 1700. To setup the 1800 routers I copied the conf from the originals. The origianl network works fine both ways with both VNC and RDP.

Any help would be greatly appreciated.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Collin Clark Tue, 12/11/2007 - 10:02

Check your TCP segment size. To find out what it should be you can try the following.

From a PC at site A, ping a PC at Site B. You need to set some ICMP switches though.

C:\>ping 10.10.2.100 -f -l 1500

The -f is set the Do Not Fragment flag, the -l is the send buffer size. Continue to do this each time decreasing the packet size until you have a successful ping. When you find that number, that is your maximum TCP segment size. You can then set that on the router. Any packet that is too big, the router will respond to the sending device saying it is too big, send a smaller size. It will do that until the packet is less than or equal to the number you set. In most routers the largest size you can set is 1460, so that might save you some time. To set it in the router, go to the tunnel interface and enter "ip tcp adjust-mss

HTH and please rate.

Actions

This Discussion