2 VLANs from one ISP

Unanswered Question

Hello,

I have new Internet provider who gives me internet in very strange way. I wanted two different speeds for local Internet(national internet, in the country only) and International (world wide). The ISP provides me with 2 VLANs one for International traffic and second for local traffic (because of the different speeds we wanted). Both VLANs consist of two IP adds with /30 masks which is normal( one IP for my device and second for their device). They gave me a range of 8 public IPs as well from different network. My question is: Do I have to setup only SVI's for these vlans or I have to create subinterfaces on the port connected to the ISP. Actually the port that will be connected to the ISP has to be a trunk(because of the two VLANs). What is the common fashion to complete this task. Do I have to setup BGP because I have to have protocol to decide where to route different internet requests. My device is 2800 Router with 12.4(3h) IOS. The termination point of the ISP is DSL. Thanks in advance!!!

Regards

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mheusing Wed, 12/12/2007 - 01:10

Hi,

I would guess the question have to be answered by the ISP, as he has to configure his side and the settings have to match.

I wuld assume two dot1Q subinterfaces on your router will be required. Routing and addressing has to be defined by the ISP. I would assume running BGP will be required to select national and worldwide routes, but again, the ISP has to agree on that.

Regards, Martin

nordick26 Wed, 12/12/2007 - 01:17

Hi,

concerning the interface config for different VLANs, you need to configure two subinterfaces for each VLAN. The config could look like this:

ex. vlan 100 and 200

interface FastEthernet0/0

description link to ISP

speed 100

no shutdown

!

interface FastEthernet0/0.100

encapsulation dot1Q 100

ip address 10.1.1.2 255.255.255.252

!

interface FastEthernet0/0.200

encapsulation dot1Q 200

ip address 10.1.1.6 255.255.255.252

Config like routing, dsl... depends on your provider and your agreement with him.

HTH

Regards

Ivan

Thank you guys, you helped alot.

Is there any way to avoide the usage of BGP. It will smack the 2800 Router I think or I have to updrade the memory. Although I have to setup VPN Server on it as well. I already spoke to the IPS and they were NOT agree to provide me with a single VLAN (that would allow me to use a single default route to their router). Is there any way to route one of the traffics (International or Local) to static route and the other with BGP?? I just want to avoid the presence of 10 screens routing table and overload on the device. Any solution without BGP will be acceptable. Thanks in advance!

Regards

nordick26 Wed, 12/12/2007 - 11:21

Hi,

to avoid the usage of BGP, you can configure static routes for your local/international subnets (if there aren't hundreds of subnets) and for the rest, lets say internet traffic, you can use a default route.

But one remark -> the fact that you are using BGP doesn't mean your routing table will have thousands of lines. I'm running BGP on 2800 series as well. You can configure route-maps by yourself or ask your provider to send you only some routes and default gateway (second case is better, because you are saving your bandwidth).

HTH

Regards

Ivan

mheusing Thu, 12/13/2007 - 02:26

Hi,

In general you need enough routing information in a router to make forwarding decisions according to your requirements.

Lets for simplicity say you have Internet access through VLAN 666 and RFC1918 networks through VLAN 100.

In this case two default routes will not help you, as the router would not have enough information to forward to f.e. 10.1.1.1. What can be done in this example is to have 3 aggregates 10.0.0.0/8, 172.16.0.0/12 and 192.168.0.0/16 pointing to VLAN 100 and a default route for the internet.

So in case you are using static routes, the question is: Can you create aggregates like in the example above, and if so, how many?

In case the number of networks it reasonably low, this can work.

In other cases you should use BGP and the ISP should filter the internet table based on your requirements and send a default route for the rest of the internet, as already described in a previous post.

Regards, Martin

Actions

This Discussion