Unity 4.05 - Starting services.

Unanswered Question
Dec 12th, 2007

I have just upgraded our Unity server from 4.04 to 4.05..

Everything seems to have installed correctly, so the pre-install check, Exchange 2000 updates, MSupdates, CD images have all loaded and installed ok..

However, upon reboot, I am now unable to reactive the Unity service.. I click on "start Unity " as normal and I can see it attempting to start the service but then it fails.. but it doesnt say why it cant start again..

As far I can see, all the other services have been reactivated again.. Have I missed something really obvious ?!!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
jonmo2578 Thu, 12/13/2007 - 02:20

Cool.. thanks Ken.

Yes, the exchange does live on the same box.. I will have another look to see what services have not been re-enabled..

Cheers

Jon.

jonmo2578 Fri, 12/14/2007 - 05:55

I have had a look in the Services and as far as I can see all the MS Exchange services are activated...

Was there a particular Exchange or any other services I should be looking out for ??

Cheers

jonmo2578 Tue, 01/08/2008 - 12:07

Thanks for all your help with this guys.. I have had another go at upgrading again and still not getting any joy.. However, I have noticed a few things in Event viewer after the Unity services fails to restart...

1/ When I try to get the service AvCsMgr to start, it generate an error stating..

"An attempt to access the Primary Exchnage Mailbox Store by AvCsMgr via MAPI has failed , your profile has not been configured "..

2/ After investigating the Cisco error codes, I tried to recreate the MAPI profile by first deleting the existing entry in the registry..

3/ Upon restart, I still get the same error stating that the profile has not been configured..

The upgrade to 4.05 has not removed any of our existing user accounts, which worked fine under 4.04.. However, I have rechecked all the profile permissions and everything seems to be in the correct groups etc..

Have I missed anything... ??

Cheers again in advance..

Dennis Aston Wed, 06/24/2009 - 07:05

Don't know if this is still an issue, probably not. I would recommend re-running the permissions wizard for unity.

Dennis Aston Fri, 12/14/2007 - 09:55

See page 15 on the pdf or section 1-3 if you prefer that way of getting to the information for the startup type defaults and recommended configuration for securing your Unity server.

http://www.cisco.com/en/US/docs/voice_ip_comm/unity/42/security/guide/ex/usgex4x.pdf

I don't run integrated Exchange so I can't offer more help than that. If anybody finds the equivalent of this document but it specifies Windows 2003 please post here as well. Some of the services are different in this document on Windows 2000 rather than Windows 2003 but it got me most of the way to where I wanted to be.

Dennis Aston Fri, 12/14/2007 - 09:57

Also, make sure you didn't install anything over Terminal Services. Bad juju. I fubar'd my failover setup doing that last weekend and spent time talking to TAC as a result.

Actions

This Discussion