FTP from VLAN1 to VLAN2 on a 3750 catalyst not possible

Unanswered Question

hi,

on a 3750 catalyst ( Version 12.2(25)SEE2 )

it's not possible to start a FTP from a client in VLAN1 to a server in VLAN2;

is the same client also in VLAN2 than it works fine...

there is no firewall/access list defined...

i get:

ftp> open xxx.xx.xx.xx

connected to xxx.xx.xx.xxx.

connection closed by Remotehost.

ftp>

a telnet and ping xxx.xx.xx.xxx is possible!

any help/idea?

thanks,

martin.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Anonymous (not verified) Thu, 12/13/2007 - 08:21

What are you using to route between the VLANs? Are you using the 3750 or an external router?

b.petronio Thu, 12/13/2007 - 08:48

So, if u could ping/telnet it between vlan's, routing is fine.

Is there any acl filtering ftp traffic ?

Best Regards,

Bruno Petrónio

1) the routing is done by the switch itself

2) no i have no "access list"

3) yes, i have the parameter ip routing

here the starting from the config:

....

....

switch 1 provision ws-c3750g-48ts

switch 2 provision ws-c3750g-48ts

switch 3 provision ws-c3750-48ts

ip subnet-zero

ip routing

no ip domain-lookup

!

!

!

!

no file verify auto

!

spanning-tree mode pvst

spanning-tree extend system-id

spanning-tree vlan 1,10-14 priority 24576

!

vlan internal allocation policy ascending

!

interface Port-channel1

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface Port-channel2

switchport trunk encapsulation dot1q

switchport mode trunk

shutdown

!

interface GigabitEthernet1/0/1

description S1svaEN1

switchport mode access

speed 1000

duplex full

spanning-tree portfast

....

....

thx,

martin

Hi Martin

Are you sure that the problem is with the 3750?

From the FTP information supplied,

ftp> open xxx.xx.xx.xx

connected to xxx.xx.xx.xxx.

connection closed by Remotehost.

ftp>

it appears that you have been connected to the server and that something on the server has then ended the session.

If there was a routing problem on the 3750 I would have expected something like the following,

H:\>ftp

ftp> open 10.10.10.1

> ftp: connect :Connection timed out

ftp>

If the server is a windows based server, is it possible that there is a local firewall (windows firewall) terminating your FTP session?

Best Regards,

Michael

Actions

This Discussion