Hunt Pilot / Pickup Group

Answered Question
Dec 13th, 2007

I have a scenario that is giving me a problem with pickup groups and I need some assistance. I have 3 extensions (1410, 1411 & 1412) that are part of a pickup group. That pickup group works fine. However, we have an after hours line group with a hunt pilot of 1420 that rings phones 1410 & 1600(broadcast). When a call goes to 1420 it rings 1410 & 1600 just fine but users at 1411 & 1412 cannot pick up the call ringing on 1410. Says call is not available. Is there a different way to set that up so it can pick up that line? I thought maybe adding 1420 to the pickup group but that does not appear to be an option. We are running CM 5.1.

Thanks

I have this problem too.
0 votes
Correct Answer by rob.huffman about 8 years 12 months ago

Hi Chris,

Here is a link to the actual Tac Case Collection for this fix. No patching or reboots should be required :)

http://www.ciscotaccc.com/kaidara-advisor/voice/showcase?case=K11612191

Hope this helps!

Rob

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (13 ratings)
Loading.
rob.huffman Thu, 12/13/2007 - 09:24

Hi Chris,

Hope all is well with you! You are on the right track with adding 1420 to the Pickup Group,but you are hitting this bug CSCsb12946 which prevents this feature from working (still applicable in 5.1);

Set enterprise parameter (System->Enterprise Parameters->Cisco Support Use 1) Cisco Support Use 1 to CSCsb42763 (case sensitive)

This operation added listbox (Route Plan->Route/Hunt->Hunt Pilot->hunt pilot XXXX -> Call Pickup Group) Call Pickup Group.

From this doc;

http://www.ciscotaccc.com/kaidara-advisor/voice/showcase?case=K11612191

1.- Enter

CSCsb42763 (in mixed case) in the Enterprise Parameter 'Cisco Support

Use 1' under the new group 'Cisco Support use Only' and click update. Only the value

CSCsb42763 in this parameter can enable the configuration. Change the

value to anything else to disable this functionality.

2. Go to Hunt Pilot Configuration page and select a call pickup group from the Call

Pickup Group dropdown list and click update.

CSCsb42763

Call Pickup fails on Hunt List

Issue:

Call pickup fails for hunt list when call is CFA from Route Point in 4.1(2)ES41. This is not the designed functionality for this issue and will break the Call Pickup logic.

Workaround:

Use multiple shared lines & CFNA between each shared line.

Related Bugs

Call Pickup fails when ringing line list member

Symptom: Selecting PickUp or GPickUp does not pickup the call from any of the members of a line group. Condition: CM 4.x Workaround: None. Feature not supported. Further Problem Description: Defect CSCsa66224 may appear to have allowed this feature to work in earlier versions.

Call Pickup from line group member fails after es installed

Symptom: A call is CFNA to a hunt pilot/line group. The call can no longer be picked up. Conditions: Calls CFNA to a hunt pilot. 4.1(2)ES36. Workaround: None

Hope this helps!

Rob

rob.huffman Thu, 12/13/2007 - 13:42

Hey Paolo,

Welcome back, and thanks for your continued kind support :)

Here is the "skinny"

This ability to add Hunt Pilot #'s to Pickup groups used to work and people got really used to it. Cisco decided that it wasn't supposed to work in the first place so they went out and broke it :( After much complaining by the masses, Cisco relented and grudgingly came up with this setting (that allowed this to work again);

Set enterprise parameter (System->Enterprise Parameters->Cisco Support Use 1) Cisco Support Use 1 to CSCsb42763

I'm not sure why they didn't just fix it ??

Take care my friend,

Huff

cyoungblut Fri, 12/14/2007 - 07:24

Just to be clear on this... by entering CSCsb42763 in this field and saving it this will give me the option to add a call pickup group to my hunt pilot number???? (Is there a patch/fix to download and put on Callmanager first?)

Also, do I need to reset and if so will it interrupt phone operation? Sorry - just want to be absolutely clear before making any changes.

Thanks again for all your help.

pkentsmith Mon, 12/17/2007 - 07:48

There is also one other 'feature' to be aware of when doing this. If you want to delete the pickup group, you need go first set the hunt pilot to use a different (or no) pickup group BEFORE trying to delete it from Feature --> Call Pickup Group

Failure to do this then means you cannot then access the hunt pilot screen and the work around for this is to delete the Hunt Pilot in SQL (there is a Cisco doc for this)

Kenneth Mohammed Tue, 09/16/2008 - 11:52

Rob..thanks for this..I was pulling my brains out trying to figure out why the call pickup wouldnt work with the hunt pilot..I followed your instructions and VOILA!! it worked..thanks again...5 points for you!!!

CiscoSeinajoki Mon, 05/11/2009 - 22:12

Thank you so very much for this! I have been struggling with this same subject for some time now, but this worked fine!

t.Satu

Alexander.Khlem... Tue, 03/25/2008 - 11:22

Just for everybody's information.

The same problem still exists in CUCM 6.0 and 6.1 and can be cured by the same method shown above.

Good luck everybody! :)

rob.huffman Wed, 03/26/2008 - 10:07

Hi Alexander,

Thanks for posting up your results :) 5 points for sharing this info for others to share!

Take care,

Rob

Keith Fulcher Mon, 10/06/2008 - 05:07

However, but activating this "Bug" in the Service Parameters can cause undocumented problems. There might be internal Cisco Documents that are more detailed, but I did a little digging and I found references to Memory Leaks and so on. I would not blindly just activate this, without consulting your Customer. There is a reason that Cisco does not have it activated themselves.

shrutid22 Sun, 02/21/2010 - 17:11

Hi There

This bug still exists in CM version 7.1.3

Is there any fix for this? How can we fix this in 7.1?

any help is appreciated

Thanks and Regards

rob.huffman Mon, 02/22/2010 - 06:23

Hi there,

The workaround listed in the Bug notes above will fix this in

CUCM 7.1 versions as well

1.- Enter

CSCsb42763 (in mixed case) in the Enterprise Parameter 'Cisco Support

Use 1' under the new group 'Cisco Support use Only' and click update.

Cheers!

Rob

Actions

This Discussion