Cisco 877w - wireless conf ig not working (config attached)

Unanswered Question
Dec 14th, 2007

Hi, I can't seem to get the wireless side working on my Cisco 877w. I can see the network when I search, but it won't assign an IP address.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
sarbjeet-dhillon Fri, 12/14/2007 - 09:01

I suggest you exclude the address which is being used as the BVI1 address.

config t

ip dhcp excluded-address

See if that resolves the problem.


Richard Burts Fri, 12/14/2007 - 09:06


While I agree that excluding the address is a good idea, I do not think that this is the basic problem here.


I believe that there are two statements that are missing in the config that are important in getting IRB to work. I suggest that you add these statements to the config:

bridge 1 protocol ieee

bridge 1 route ip

give this a try and let us know if it helps.



yenlung Thu, 12/20/2007 - 22:35

bridge 1 route ip will do the trick

This command will tell the ethernet and the wireless to bridge together using IP.

Hope this helps.

whiteford Fri, 12/21/2007 - 03:26

I'm off work now so can't test. So I just need to run "no ip address" under the BVI interface to get rid the IP? And then run "bridge 1 route ip" in global mode and that's it? So it will use one ip range? I notice alot of configs use the BVI as the main router address, does it matter if I use the BVI or VLAN 1 as the routers IP?

Richard Burts Fri, 12/21/2007 - 05:35


I do not believe that anyone has suggested no ip address for the BVI interface. To enable routing of IP through the bridged interface(s) the BVI must have an IP address.

As far as I know you have a choice about how to configure your router for its VLAN 1 and its wireless. You can give VLAN 1 an address and route that VLAN separately (do not enable bridging on it) and give the BVI an address in a different subnet and route it. Or you can give the VLAN 1 no ip address, enable bridging on VLAN 1, and have the devices on VLAN 1 share the subnet with the wireless devices.



whiteford Fri, 12/21/2007 - 05:43

Sorry Rick, I meant the VLAN 1 for the no IP. So if I only configure teh BVI (new to me) then the wireless and LAN will use the same IP range to keep things nice and simple?

I take this BVI interface will be the routers IP?

Richard Burts Fri, 12/21/2007 - 05:50


If you do not configure an IP address on VLAN 1 and if you enable bridging on VLAN 1 then VLAN 1 and the wireless will share the same IP range.

The BVI can function as one of the addresses of the router. It obviously needs at least one other IP address for its connection to outside. And it could have loopback addresses for management if desired.



whiteford Fri, 12/21/2007 - 06:30

This is clearer now. I'm use to configuring 877's and only ever add a single address to the VLAN 1 to give the router it's inside IP. Now I have an 877w to work with in my head it seems I should have a single subnet for the wireless and wired users. I suppose I can treat the BVI just lke the VLAN 1 I'm use to?

And my DHCP scope would work for both wired and wireless too?

I never have had to configure an outside IP before as my ISP just gives me a static IP which I use for VPN reasons. In some scenarios would I need to tell VLAN 1 or the BVI interface what my ouside IP is?

Thanks (again)


This Discussion