Ping fails

Unanswered Question
Dec 16th, 2007
User Badges:

can someone explain why from a pc directly connected to a router ethernet interface pings the ethernet interface ok but cannot ping the serial interface on the same router. Serial interface is connected with back to back cable with another router and protocol is up.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Edison Ortiz Sun, 12/16/2007 - 08:11
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

The serial interface belongs to another IP subnet.

Does the PC has a route to the serial interface with a gateway of the LAN interface ?

or

a default route pointing to the LAN interface of such router ?


aconticisco Sun, 12/16/2007 - 12:44
User Badges:

yes to give you more details my nic ip address is 10.0.0.1/8 gateway 10.0.0.200 Router lan interface ip 10.0.0.200 router serial interface ip 192.168.2.250

when I ping the serial interface I get request timed out, the router should forward the packet to the serial interface and return the icmp reply back am I correct ?

Edison Ortiz Sun, 12/16/2007 - 12:54
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Correct.


Can the router ping its own serial interface ?

Edison Ortiz Sun, 12/16/2007 - 13:20
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Check for any FW on the PC or an ACL in the LAN interface at the router.


Additionally, let's see the IPCONFIG /ALL from the PC and show run from the router.

deepinder Sun, 12/16/2007 - 13:21
User Badges:


Hi,


Check if there is any access list applied on serial or ethernet interface blocking the ping from ur PC.


HTH

Deepinder Singh Babbar

aconticisco Sun, 12/16/2007 - 13:55
User Badges:

I think that a firewall problem on my pc should be excluded since I can ping the lan interface of the router, am I correct ? I will check for any access-lists and also post run conf and pc ip conf all in a few minutes

aconticisco Sun, 12/16/2007 - 14:08
User Badges:

I types show access-lists and it gave nothing. here is my run conf

RouterA#show access-lists


RouterA#show run

Building configuration...


Current configuration : 1038 bytes

!

version 12.3

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname RouterA

!

boot-start-marker

boot system tftp c1600z.123-6.bin 10.0.0.1

boot system flash c1600-sy-mz.122-3.bin

boot system rom

boot-end-marker

!

enable password 7 094D5E

!

no aaa new-model

ip subnet-zero

ip domain name andrea.com

ip name-server 10.0.0.1

!

!

!

!

!

!

!

interface Loopback2

ip address 172.0.0.200 255.255.0.0

!

interface Ethernet0

ip address 10.0.0.200 255.0.0.0

!

interface Serial0

bandwidth 1000

ip address 192.168.2.250 255.255.255.0

clockrate 1000000

no fair-queue

!

router ospf 100

log-adjacency-changes

network 10.0.0.0 0.255.255.255 area 0

network 192.168.2.0 0.0.0.255 area 0

!

ip classless

no ip http server

no ip http secure-server

!

!

!

banner motd ^C That's Better ^C

!

line con 0

exec-timeout 0 0

password 7 08205C

login

transport preferred all

transport output all

line vty 0 4

password 7 15131B

login

transport preferred all

transport input all

transport output all

!

!

end


Windows IP Configuration



Ethernet adapter to cisco 1600 A:


Connection-specific DNS Suffix . :

Link-local IPv6 Address . . . . . : fe80::45ea:b102:be6d:6699%23

IPv4 Address. . . . . . . . . . . : 10.0.0.1

Subnet Mask . . . . . . . . . . . : 255.0.0.0

Default Gateway . . . . . . . . . : 10.0.0.200


Ethernet adapter connected to internet:


Connection-specific DNS Suffix . :

Link-local IPv6 Address . . . . . : fe80::599c:cca:5df1:d536%21

IPv4 Address. . . . . . . . . . . : 172.0.0.60

Subnet Mask . . . . . . . . . . . : 255.255.0.0

Default Gateway . . . . . . . . . : 172.0.0.50


Ethernet adapter Loopback for testing:


Connection-specific DNS Suffix . :

Link-local IPv6 Address . . . . . : fe80::3823:fa39:f739:f8e9%18

IPv4 Address. . . . . . . . . . . : 192.168.1.1

Subnet Mask . . . . . . . . . . . : 255.255.255.0

Default Gateway . . . . . . . . . :


Ethernet adapter Local Area Connection 2:


Media State . . . . . . . . . . . : Media disconnected

Connection-specific DNS Suffix . :


Ethernet adapter NAT to internet:


Connection-specific DNS Suffix . : gateway.2wire.net

Link-local IPv6 Address . . . . . : fe80::e45c:1e97:a735:bbd3%8

IPv4 Address. . . . . . . . . . . : 192.168.1.104

Subnet Mask . . . . . . . . . . . : 255.255.255.0

Default Gateway . . . . . . . . . : 192.168.1.254


Tunnel adapter Local Area Connection* 6:


Connection-specific DNS Suffix . : gateway.2wire.net

Link-local IPv6 Address . . . . . : fe80::5efe:192.168.1.104%26

Default Gateway . . . . . . . . . :


Tunnel adapter Local Area Connection* 14:


Connection-specific DNS Suffix . :

Temporary IPv6 Address. . . . . . : 2002:ac00:3c::ac00:3c

Default Gateway . . . . . . . . . : 2002:c058:6301::c058:6301


Tunnel adapter Local Area Connection* 9:


Media State . . . . . . . . . . . : Media disconnected

Connection-specific DNS Suffix . :


Tunnel adapter Local Area Connection* 10:


Media State . . . . . . . . . . . : Media disconnected

Connection-specific DNS Suffix . :


Tunnel adapter Local Area Connection* 16:


Connection-specific DNS Suffix . :

Link-local IPv6 Address . . . . . : fe80::5efe:192.168.1.1%20

Default Gateway . . . . . . . . . :


Tunnel adapter Local Area Connection* 19:


Connection-specific DNS Suffix . :

Link-local IPv6 Address . . . . . : fe80::200:5efe:172.0.0.60%25

Default Gateway . . . . . . . . . :


Tunnel adapter Local Area Connection* 20:


Connection-specific DNS Suffix . :

Link-local IPv6 Address . . . . . : fe80::5efe:10.0.0.1%27

Default Gateway . . . . . . . . . :




Jon Marshall Sun, 12/16/2007 - 14:20
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Hi


You seem to have at least 3 different default-gateways on your PC.


Can you run a "netstat -nr" on your PC to have a look at the routing table.


To check whether this is the issue on your PC from a cmd prompt


route add 192.168.2.0 mask 255.255.255.0 10.0.0.200


HTH


Jon

aconticisco Sun, 12/16/2007 - 14:28
User Badges:

===========================================================================

Interface List

23 ...00 0a cd 07 44 a8 ...... Realtek RTL8139/810x Family Fast Ethernet NIC #2

21 ...00 50 bf 06 3e 27 ...... Realtek RTL8139/810x Family Fast Ethernet NIC

18 ...02 00 4c 4f 4f 50 ...... Microsoft Loopback Adapter

11 ...22 22 22 22 22 22 ...... Bluetooth PAN Network Adapter

8 ...00 0c 6e fb 98 bf ...... VIA Rhine II Compatible Fast Ethernet Adapter

1 ........................... Software Loopback Interface 1

26 ...00 00 00 00 00 00 00 e0 isatap.gateway.2wire.net

28 ...00 00 00 00 00 00 00 e0 6TO4 Adapter

10 ...02 00 54 55 4e 01 ...... Teredo Tunneling Pseudo-Interface

15 ...00 00 00 00 00 00 00 e0 isatap.{0B8AD8E2-F222-4D54-99CB-89DEF8EA1138}

20 ...00 00 00 00 00 00 00 e0 isatap.{F2B187DD-14C8-4227-BE1A-09A1AF315CBD}

25 ...00 00 00 00 00 00 00 e0 isatap.{A2F9967D-2AEC-4A14-93C9-D6665EC877AF}

27 ...00 00 00 00 00 00 00 e0 isatap.{2C61AD31-7461-4F7E-B80B-7944B7886233}

===========================================================================


IPv4 Route Table

===========================================================================

Active Routes:

Network Destination Netmask Gateway Interface Metric

0.0.0.0 0.0.0.0 10.0.0.200 10.0.0.1 286

0.0.0.0 0.0.0.0 172.0.0.50 172.0.0.60 286

0.0.0.0 0.0.0.0 192.168.1.254 192.168.1.104 20

10.0.0.0 255.0.0.0 On-link 10.0.0.1 286

10.0.0.1 255.255.255.255 On-link 10.0.0.1 286

10.255.255.255 255.255.255.255 On-link 10.0.0.1 286

127.0.0.0 255.0.0.0 On-link 127.0.0.1 306

127.0.0.1 255.255.255.255 On-link 127.0.0.1 306

127.255.255.255 255.255.255.255 On-link 127.0.0.1 306

172.0.0.0 255.255.0.0 On-link 172.0.0.60 286

172.0.0.60 255.255.255.255 On-link 172.0.0.60 286

172.0.255.255 255.255.255.255 On-link 172.0.0.60 286

192.168.1.0 255.255.255.0 On-link 192.168.1.1 286

192.168.1.0 255.255.255.0 On-link 192.168.1.104 276

192.168.1.1 255.255.255.255 On-link 192.168.1.1 286

192.168.1.104 255.255.255.255 On-link 192.168.1.104 276

192.168.1.255 255.255.255.255 On-link 192.168.1.1 286

192.168.1.255 255.255.255.255 On-link 192.168.1.104 276

224.0.0.0 240.0.0.0 On-link 127.0.0.1 306

224.0.0.0 240.0.0.0 On-link 192.168.1.1 286

224.0.0.0 240.0.0.0 On-link 10.0.0.1 286

224.0.0.0 240.0.0.0 On-link 172.0.0.60 286

224.0.0.0 240.0.0.0 On-link 192.168.1.104 276

255.255.255.255 255.255.255.255 On-link 127.0.0.1 306

255.255.255.255 255.255.255.255 On-link 192.168.1.1 286

255.255.255.255 255.255.255.255 On-link 10.0.0.1 286

255.255.255.255 255.255.255.255 On-link 172.0.0.60 286

255.255.255.255 255.255.255.255 On-link 192.168.1.104 276

===========================================================================

Persistent Routes:

Network Address Netmask Gateway Address Metric

0.0.0.0 0.0.0.0 10.0.0.200 Default

0.0.0.0 0.0.0.0 172.0.0.50 Default

===========================================================================


IPv6 Route Table

===========================================================================

Active Routes:

If Metric Network Destination Gateway

28 1140 ::/0 2002:c058:6301::c058:6301

1 306 ::1/128 On-link

28 1040 2002::/16 On-link

28 296 2002:ac00:3c::ac00:3c/128

On-link

18 286 fe80::/64 On-link

23 286 fe80::/64 On-link

21 286 fe80::/64 On-link

8 276 fe80::/64 On-link

27 296 fe80::5efe:10.0.0.1/128 On-link

20 296 fe80::5efe:192.168.1.1/128

On-link

26 281 fe80::5efe:192.168.1.104/128

On-link

25 296 fe80::200:5efe:172.0.0.60/128

On-link

18 286 fe80::3823:fa39:f739:f8e9/128

On-link

23 286 fe80::45ea:b102:be6d:6699/128

On-link

21 286 fe80::599c:cca:5df1:d536/128

On-link

8 276 fe80::e45c:1e97:a735:bbd3/128

On-link

1 306 ff00::/8 On-link

18 286 ff00::/8 On-link

23 286 ff00::/8 On-link

21 286 ff00::/8 On-link

8 276 ff00::/8 On-link

===========================================================================

Persistent Routes:

None


c:\Users\main\route add 192.168.2.0 255.255.255.0.10.0.0.200

route: bad argument 10.0.0.200


route add gave me the above error


Now I have to go but will be back trying to fix the problem tomorrow evening, thank you for your help and hope I can fix it.

Jon Marshall Sun, 12/16/2007 - 14:31
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Hi


You missed out the word "mask" in the command ie. you entered


route add 192.168.2.0

255.255.255.0.10.0.0.200



and it should be


route add 192.168.2.0 mask 255.255.255.0 10.0.0.200


Jon

Actions

This Discussion