etherchannel between catalyst 4908G and 3750G

Unanswered Question
Dec 16th, 2007
User Badges:

hi all,

just want to post a situation here. i have 2 catalyst 4908G (8-port) with

bridging enabled. it was configured to run as redundant switch router for vlan

with port #8 configured as etherchannel connected to port #8 of the second switch

with port-channel subinterface and encapsulation configured as well.


everything works fine until the second switch fails.

we replaced the second switch with catalyst 3750G (12 port). the bridging was

configured and port #12 was assigned to connect to port #8 of the catalyst 4908G

but unfortunately i cannot ping the ip address of the bridge of the catalyst 3750 from

our network neither i can ping the ip address of the bridge of catalyst 4908G from the console

of the 3750 switch. what seems to be the problem?

all interfaces were verified as up and running.


the following are the configuration of the bridge and etherchannel of the 2 switches:


catalyst 4908G:


interface port-channel1

no ip address

no ip directed-broadcast

hold-queue 300 in

!

interface port-channel1.1

encapsulation isl 1

no ip redirects

no ip directed-broadcast

bridge-group 1


---output cut


!

interface GigabitEthernet8

no ip address

no ip directed broadcast

channel-group 1


!

interface Bvi1

ip address 172.25.x.x netmask

ip helper-address 172.25.a.b

no ip redirects

no ip directed-broadcast

standby 1 priority 105 preempt

standby 1 ip 172.25.1.1



---output cut



catalyst 3750

!

interface port-channel1

hold-queue 300 in


---output cut

!

interface GigabitEthernet12

channel-group 1 on

!

interface Bvi1

ip address 172.25.x.y netmask

no ip route-cache cef

standby 1 preempt

standby 1 ip 172.25.1.1

!


---output cut







  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Edison Ortiz Sun, 12/16/2007 - 10:55
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Any reason why are you bridging ? The switch bridges by default, no need to use BVI.


This configuration would be useful when you have a router and you want this router to behave like a switch.


I also don't see the need for etherchanneling on a single link. Etherchanneling is used when you want to bundle 2 or more links for bandwidth aggregation and/or faul tolerance.



Your configuration should be as follow:


catalyst 4908G:


interface GigabitEthernet8

switchport trunk encapsulation dot1q

switchport mode trunk


interface vlan 1

ip address 172.25.x.x netmask

ip helper-address 172.25.a.b

no ip redirects

no ip directed-broadcast

standby 1 priority 105 preempt

standby 1 ip 172.25.1.1


catalyst 3750


interface GigabitEthernet12

switchport trunk encapsulation dot1q

switchport mode trunk


interface vlan 1

ip address 172.25.x.y netmask

standby 1 preempt

standby 1 ip 172.25.1.1

!





agfernando Sun, 12/16/2007 - 11:31
User Badges:

thank you for your quick response mr. EdisonOrtiz. i do have a router. basically the function of those 2 switches is to work redundantly if either of them fails one of them will be up and running. i've tried to shut down the first switch (4908G) to see if the second switch (3750) will provide the network connectivity but it fails. i cannot ping any ip address in the network. do you think the trunking from 4908G to 3750G will resolve the problem in the 3750G switch?

agfernando Sun, 12/16/2007 - 11:50
User Badges:

thank you for your quick response mr. EdisonOrtiz. i do have a router. the reason i used bridge is to group all subinterfaces that i configured for vlan trunk. basically the function of those 2 switches is to work redundantly(STP)if either of them fails one of them will be up and running. i've tried to shut down the first switch (4908G) to see if the second switch (3750) will provide the network connectivity but it fails. i cannot ping any ip address in the network. do you think the trunking from 4908G to 3750G will resolve the problem in the 3750G switch?

Edison Ortiz Sun, 12/16/2007 - 12:56
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

I meant, the BVI configuration will be on a router, not that you need BVI if you have a router in the topology.


Please follow my suggestions to make this work.

agfernando Thu, 01/03/2008 - 11:48
User Badges:

Sir EdisonOrtiz,


How are you Sir? I tried the configuration that you gave me but the problem is that 4908G switch was not recognized switchport command thus I cannot make the interface as trunk. So still i cannot connect to my 3750 switch. By the way the reason for BVI configuration was for routing. and for you to have a better feel of our switch configuration below is the configuration for both 4908G and 3750 switch. note: 4908G switch is the active.


4908G-L3 config:


bridge irb

!

!

!

interface Port-channel1

no ip address

no ip directed-broadcast

hold-queue 300 in

!

interface Port-channel1.1

encapsulation isl 1

no ip redirects

no ip directed-broadcast

bridge-group 1

!

interface GigabitEthernet1

no ip address

no ip directed-broadcast

!

interface GigabitEthernet1.1

encapsulation isl 1

no ip redirects

no ip directed-broadcast

bridge-group 1

!

interface GigabitEthernet1.10

encapsulation isl 10

ip address 172.25.x.y 255.255.b.z

ip helper-address 172.25.a.a

no ip redirects

no ip directed-broadcast

standby 10 priority 105 preempt

standby 1 ip 172.25.f.g

!

interface GigabitEthernet2

no ip address

no ip directed-broadcast

!

interface GigabitEthernet2.1

encapsulation isl 1

no ip redirects

no ip directed-broadcast

bridge-group 1

!

interface GigabitEthernet2.20

encapsulation isl 20

ip address 172.25.x.y 255.255.b.z

ip helper-address 172.25.a.a

no ip redirects

no ip directed-broadcast

standby 20 priority 105 preempt

standby 1 ip 172.25.f.g

!

interface GigabitEthernet3

no ip address

no ip directed-broadcast

!

interface GigabitEthernet3.1

encapsulation isl 1

no ip redirects

no ip directed-broadcast

bridge-group 1

!

interface GigabitEthernet3.30

encapsulation isl 30

ip address 172.25.x.y 255.255.b.z

ip helper-address 172.25.a.a

no ip redirects

no ip directed-broadcast

standby 30 priority 105 preempt

standby 1 ip 172.25.f.g

!

interface GigabitEthernet4

no ip address

no ip directed-broadcast

!

interface GigabitEthernet4.1

encapsulation isl 1

no ip redirects

no ip directed-broadcast

bridge-group 1

!

interface GigabitEthernet4.40

encapsulation isl 40

ip address 172.25.x.y 255.255.b.z

ip helper-address 172.25.a.a

no ip redirects

no ip directed-broadcast

standby 40 priority 105 preempt

standby 1 ip 172.25.f.g

!

interface GigabitEthernet5

no ip address

no ip directed-broadcast

!

interface GigabitEthernet5.1

encapsulation isl 1

no ip redirects

no ip directed-broadcast

bridge-group 1

!

interface GigabitEthernet5.50

encapsulation isl 50

ip address 172.25.x.y 255.255.b.z

ip helper-address 172.25.a.a

no ip redirects

no ip directed-broadcast

standby 50 preempt

standby 1 ip 172.25.f.g

!

interface GigabitEthernet6

no ip address

no ip directed-broadcast

!

interface GigabitEthernet6.1

encapsulation isl 1

no ip redirects

no ip directed-broadcast

bridge-group 1

!

interface GigabitEthernet6.60

encapsulation isl 60

ip address 172.25.x.y 255.255.b.z

ip helper-address 172.25.a.a

no ip redirects

no ip directed-broadcast

standby 60 preempt

standby 1 ip 172.25.f.g

!

interface GigabitEthernet7

no ip address

no ip directed-broadcast

!

interface GigabitEthernet7.1

encapsulation isl 1

no ip redirects

no ip directed-broadcast

bridge-group 1

!

interface GigabitEthernet7.70

encapsulation isl 70

ip address 172.25.x.y 255.255.b.z

ip helper-address 172.25.a.a

no ip redirects

no ip directed-broadcast

standby 70 preempt

standby 1 ip 172.25.f.g

!

interface GigabitEthernet8

no ip address

no ip directed-broadcast

channel-group 1

!

interface BVI1

ip address 172.25.x.y 255.255.b.z

ip helper-address 172.25.a.a

no ip redirects

no ip directed-broadcast

standby 1 priority 105 preempt

standby 1 ip 172.25.f.g

!

router eigrp 200

network 172.25.0.0

no auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.25.d.e

!


bridge 1 protocol ieee

bridge 1 route ip

!

end



3750 switch config:

bridge irb

!

interface Port-channel1

hold-queue 300 in

!

interface GigabitEthernet1/0/1

no switchport

ip address 172.25.x.y 255.255.b.z

ip helper-address 172.25.a.a

standby 10 ip 172.25.f.g

standby 10 preempt

bridge-group 1

no shutdown

!

interface GigabitEthernet1/0/2

no switchport

ip address 172.25.x.y 255.255.b.z

ip helper-address 172.25.a.a

standby 20 ip 172.25.f.g

standby 20 preempt

bridge-group 1

no shutdown

!

interface GigabitEthernet1/0/3

no switchport

ip address 172.25.x.y 255.255.b.z

ip helper-address 172.25.a.a

standby 30 ip 172.25.f.g

standby 30 preempt

bridge-group 1

no shutdown

!

interface GigabitEthernet1/0/4

no switchport

ip address 172.25.x.y 255.255.b.z

ip helper-address 172.25.a.a

standby 40 ip 172.25.f.g

standby 40 preempt

bridge-group 1

no shutdown

!

interface GigabitEthernet1/0/5

no switchport

ip address 172.25.x.y 255.255.b.z

ip helper-address 172.25.a.a

standby 50 ip 172.25.f.g

standby 50 preempt

standby 50 priority 105

bridge-group 1

no shutdown

!

interface GigabitEthernet1/0/6

no switchport

ip address 172.25.x.y 255.255.b.z

ip helper-address 172.25.a.a

standby 60 ip 172.25.f.g

standby 60 preempt

standby 60 priority 105

bridge-group 1

no shutdown

!

interface GigabitEthernet1/0/7

no switchport

ip address 172.25.x.y 255.255.b.z

ip helper-address 172.25.a.a

standby 70 ip 172.25.f.g

standby 70 preempt

standby 70 priority 105

bridge-group 1

no shutdown

!

interface GigabitEthernet1/0/8

!

interface GigabitEthernet1/0/9

!

interface GigabitEthernet1/0/10

!

interface GigabitEthernet1/0/11

!

interface GigabitEthernet1/0/12

channel-group 1 mode on

no shutdown

!

interface BVI1

ip address 172.25.x.y 255.255.b.z

ip helper-address 172.25.a.a

no ip route-cache cef

standby 1 preempt

standby 1 ip 172.25.f.g

!

exit

!

bridge 1 protocol vlan-bridge

bridge 1 route ip

!

ip routing

router eigrp 200

network 172.25.0.0

no auto-summary

!

exit

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.25.d.e

!

end






Actions

This Discussion