Nat or ACL Problem?

Answered Question
Dec 17th, 2007
User Badges:

New ASA5505 configured with ASDM. Tried to get the config running on 8.03 and the current 7.23.


What I want to do is setup a list of our Static IP's and allow only them to access a Terminal Server using only the TS ports specified in a TCP Service Group. The config I have looks very much like the config I have in another ASA5510 which is working fine.

When I try to connect from the defined static IP static1 via the RDP client I can see it being block in the syslog.


Deny tcp src outside:static1/31856 dst inside:xxx.xxx.xx.xxx/3389 by access-group "outside_access_in" [0x0, 0x0]


I am at a loss as I think I have the Static NAT and ACL correct.


Thanks for any help

Regards,

Brad


ASA5505 Config:


: Saved

:

ASA Version 7.2(3)

!

hostname ciscoasa

domain-name default.domain.invalid

enable password xxx

names

name 208.x.x.111 static1

name 192.168.1.25 temptermserv

!

interface Vlan1

nameif inside

security-level 100

ip address 192.168.1.222 255.255.255.0

!

interface Vlan2

nameif outside

security-level 0

ip address dhcp setroute

!

interface Ethernet0/0

switchport access vlan 2

!

interface Ethernet0/1

!

interface Ethernet0/2

!

interface Ethernet0/3

!

interface Ethernet0/4

!

interface Ethernet0/5

!

interface Ethernet0/6

!

interface Ethernet0/7

!

passwd xxx

boot system disk0:/asa723-k8

ftp mode passive

dns server-group DefaultDNS

domain-name default.domain.invalid

object-group network YPMStatics

network-object host static1

object-group service termservports tcp

port-object range 3389 3389

port-object range www www

port-object eq citrix-ica

access-list outside_access_in extended permit tcp object-group YPMStatics object-group termservports host temptermserv object-group termservports

pager lines 24

logging enable

logging asdm informational

mtu outside 1500

mtu inside 1500

icmp unreachable rate-limit 1 burst-size 1

asdm image disk0:/asdm-523

no asdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 1 0.0.0.0 0.0.0.0

static (inside,outside) interface temptermserv netmask 255.255.255.255

access-group outside_access_in in interface outside

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout uauth 0:05:00 absolute

http server enable

http 192.168.1.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart

telnet timeout 5

ssh timeout 5

console timeout 0

dhcpd auto_config outside

!

dhcpd address 192.168.1.100-192.168.1.200 inside

dhcpd dns 198.161.156.1 207.194.28.230 interface inside

dhcpd enable inside

!


!

class-map inspection_default

match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

parameters

message-length maximum 512

policy-map global_policy

class inspection_default

inspect dns preset_dns_map

inspect ftp

inspect h323 h225

inspect h323 ras

inspect rsh

inspect rtsp

inspect esmtp

inspect sqlnet

inspect skinny

inspect sunrpc

inspect xdmcp

inspect sip

inspect netbios

inspect tftp

!

service-policy global_policy global

prompt hostname context

Cryptochecksum:xxx

: end

asdm image disk0:/asdm-523

no asdm history enable

Correct Answer by husycisco about 9 years 7 months ago

Ah sorry Brad, my bad. Do this


access-list outside_access_in extended permit tcp object-group YPMStatics interface outside object-group termservports


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
husycisco Mon, 12/17/2007 - 11:04
User Badges:
  • Gold, 750 points or more

Hi Brad

In your ACL, you permit YPMStatics hosts to establish connection from termservports to host temptermserv on termservports. But from port is a randomly created port so you shouldnt specify it in ths case. Do the following modification


no access-list outside_access_in extended permit tcp object-group YPMStatics object-group termservports host temptermserv object-group termservports

access-list outside_access_in extended permit tcp object-group YPMStatics host temptermserv object-group termservports


Regards

wipper101 Mon, 12/17/2007 - 11:22
User Badges:

I did make the change (had it this way when I tried the 8.0.3 image).

It now says:


access-list outside_access_in extended permit tcp object-group YPMStatics host temptermserv object-group termservports


But I still get the syslog error

Deny tcp .... by access-group "outside_access_in"


Thanks for the help.

Regards,

Brad

Correct Answer
husycisco Mon, 12/17/2007 - 11:27
User Badges:
  • Gold, 750 points or more

Ah sorry Brad, my bad. Do this


access-list outside_access_in extended permit tcp object-group YPMStatics interface outside object-group termservports


wipper101 Mon, 12/17/2007 - 11:32
User Badges:

Thanks husycisco, that worked like a charm I can get some sleep tonight.


Cheers!

Brad

Actions

This Discussion