Rate-limiting on 3550 by IP addresses

Unanswered Question
Dec 17th, 2007

I've looked over this forum and can't seem to find an answer. I have a 3550 with several customers can I rate-limit egress and ingress by IP addresses?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
darrenj Mon, 12/17/2007 - 14:29

Hey there. Yes you can do this, but you can only apply the policy-map ingress to an interface (not egress).


I want to rate-limit traffic coming into fastethernet 0/1. Traffic sourced from 10.1.1.x is policed/rate-limited to 1mbps and traffic sourced from 20.1.1.x is policed/rate-limited to 9mbps. Check out the config:

class-map match-all 20Network

match access-group 2

class-map match-all 10Network

match access-group 1



policy-map My-test-ratelimit

class 10Network

police 1000000 8000 exceed-action drop

class 20Network

police 9000000 8000 exceed-action drop




interface FastEthernet0/1

service-policy input My-test-ratelimit


access-list 1 permit

access-list 1 deny any

access-list 2 permit

access-list 2 deny any


Hope this helps. Please rate all helpful posts.


sjonessha Mon, 12/17/2007 - 15:00

That looks good. At least ingress is the most important (downloads).


This Discussion