Radius failure

Unanswered Question
Dec 17th, 2007

Hi, i suddenly lost all the users from my LNS and in the log appeared the following message :

. %RADIUS-4-RADIUS_DEAD: RADIUS server x.x.x.x:1812,1813 is not responding.

. %RADIUS-4-RADIUS_ALIVE: RADIUS server x.x.x.x:1812,1813 has returned.

. %RADIUS-4-RADIUS_DEAD: RADIUS server x.x.x.x:1812,1813 is not responding.

. %RADIUS-4-RADIUS_ALIVE: RADIUS server x.x.x.x:1812,1813 has returned.

. %RADIUS-4-RADIUS_DEAD: RADIUS server x.x.x.x:1812,1813 is not responding.

. %RADIUS-4-RADIUS_ALIVE: RADIUS server x.x.x.x:1812,1813 has returned.

. %RADIUS-4-RADIUS_DEAD: RADIUS server x.x.x.x:1812,1813 is not responding.

. %RADIUS-4-RADIUS_ALIVE: RADIUS server x.x.x.x:1812,1813 has returned.

. %RADIUS-4-RADIUS_DEAD: RADIUS server x.x.x.x:1812,1813 is not responding.

. %RADIUS-4-RADIUS_ALIVE: RADIUS server x.x.x.x:1812,1813 has returned.

. %RADIUS-4-RADIUS_DEAD: RADIUS server x.x.x.x:1812,1813 is not responding.

. %RADIUS-4-RADIUS_ALIVE: RADIUS server x.x.x.x:1812,1813 has returned.

. %RADIUS-4-RADIUS_DEAD: RADIUS server x.x.x.x:1812,1813 is not responding.

. %RADIUS-4-RADIUS_ALIVE: RADIUS server x.x.x.x:1812,1813 has returned.

. %RADIUS-4-RADIUS_DEAD: RADIUS server x.x.x.x:1812,1813 is not responding.

. %RADIUS-4-RADIUS_ALIVE: RADIUS server x.x.x.x:1812,1813 has returned.

. %RADIUS-4-RADIUS_DEAD: RADIUS server x.x.x.x:1812,1813 is not responding.

. %RADIUS-4-RADIUS_ALIVE: RADIUS server x.x.x.x:1812,1813 has returned.

. %RADIUS-4-RADIUS_DEAD: RADIUS server x.x.x.x:1812,1813 is not responding.

. %RADIUS-4-RADIUS_ALIVE: RADIUS server x.x.x.x:1812,1813 has returned.

. %RADIUS-4-RADIUS_DEAD: RADIUS server x.x.x.x:1812,1813 is not responding.

What does this mean? Also the users are being authenticated by the radius really really slow with a lot of timeouts in show radius statistics. What can i do in that case in order to prevent future incidents?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 2 (1 ratings)
Loading.
Jon Marshall Tue, 12/18/2007 - 00:49

Hi

The most obvious thing to check is the connectivity between the Radius server and any devices using it for authenticaiton/authorization.

From the output above it looks like packets are going missing between the LNS and the radius server which would explain why the authentication of users is so slow. This could be caused by

1) The radius server itself. Do any other devices use this server and are they complaining about a non-responsive server

2) The LNS

3) The network between the LNS and the radius server.

Jon

v.matiakis Tue, 12/18/2007 - 00:56

In fact long after this message stopped, the users still logged in really slow. There was another LNS that did not have the same issue, the users logged in just fine. The configuration :

radius-server dead-criteria tries 2

radius-server host x.x.x.x auth-port 1812 acct-port 1813

radius-server host x.x.x.x auth-port 1812 acct-port 1813

radius-server source-ports extended

radius-server retransmit 1

radius-server timeout 15

radius-server deadtime 30.

Actions

This Discussion