RME 4.0 Device Update issue

Unanswered Question
Dec 18th, 2007

I tried to do an update from LMS file system of several RME 4.0 packages and I got the following messages:

The Package(s) Selected for Install :

Number of Packages Selected for Install : 3

For Product(s) : Resource Manager Essentials

Install Invoked by user : admin

The Package(s) Selected for Install :

Cat3750, LibInventory, SharedInventoryCatSwitch

WARNING : Cat3750(3.0):Consistency check failed for base package SharedInventoryCatIOS

WARNING : SharedInventoryCatSwitch(2.1):Consistency check failed for base package LibInventory

No package(s) to install for : Resource Manager Essentials

It's a LMS 2.6 on Windows 2000 SP4.

I didn't have this kind of error before.

Do you have any idea ?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.5 (2 ratings)
Martin Ermel Tue, 12/18/2007 - 04:28

if you update the pkgs from the local filesystem you have to take care of the correct sequence yourself, i.e in general you 'll need 3 seperate jobs: first the Libxxx pkgs, second the Sharedxxx and the last one the device pkgs.

This is time consuming because of the services restart but it works!

ppoiron Tue, 12/18/2007 - 07:06

I tried LibInventory first and it worked.

But for SharedInventory, I got the same message as previously.

Do you know what means Consistency check failed for base package LibInventory ?

ppoiron Tue, 12/18/2007 - 07:35

It could be a solution but I'm afraid to do it and not to be able to reinstall the package after deleting.

Joe Clarke Tue, 12/18/2007 - 09:04

This error means that you are missing dependent packages. The psu.log will list which packages are missing. If you are doing an update from the file system, it could be that you have not downloaded enough packages to satisfy the dependency tree.

ppoiron Tue, 12/18/2007 - 09:14

You're certainly right.

In the psu.log, I have this message:

Dependent package[LibInventory] present in source location has lower version than needed

I've just installed the LibInventory package version 1.11.2.

In the readme file of the SharedInventory package, we need V1.11.1 of LibInventory which is less than I've installed.

Joe Clarke Tue, 12/18/2007 - 09:28

If a package requires a version less than the current version, that is fine. But something must be requiring LibInventory 1.11.2. Now that you've installed it. Note, the latest LibInventory is 1.11.4 which is part of the recent RME 4.0.6 update. If you upgrade to Common Services 3.0.6 and RME 4.0.6 you will have all the recent packages.

ppoiron Wed, 12/19/2007 - 01:33

Thanks for reply.

Effectively, I planned to install these packages, but before that I will check them in my lab.

ppoiron Wed, 12/19/2007 - 02:32

I looked for these patches on CCO.

I found RME.4.0.6 but I didn't find CS.3.0.6 in the CS patch list which is a pre-requisite for the RME patch.

Perhaps, I missed something ?


This Discussion