Cdr Report ,..30023

Answered Question
Dec 18th, 2007
User Badges:

Hi all.

I have problems when I want to get a call report by CDR.

Only an interval time is available , until 26 october 2007, and message "30023:Data is not available for the date range" is shown.

I saw other users with the same problem at this forum and all replys talk about a Cisco link .I have tried to solve the problem following cisco link instructions but I can't solve it because:


-I have records when I open the CallDetailRecord in SQL , the last record is 26 october 2007 , so I executed the SQL querys and restart Car service.

-I executed an other SQL query to Know if "coments" column exceeds 256 characters with a result of 251.


After all this steps , the message 30023:Data is not available for the date range , keeps on showing.


Do anybody Know what else I have to do or what I'm doing bad?


Correct Answer by jbarcena about 9 years 7 months ago

This is a really really common issue, try the following this normally fixes the problem 95% of the times:


>>>Verify that "Cisco CDR Insert" and "Cisco CDR Analysis and Reporting Scheduler" services are running ONLY in the Publisher Call Manager:


in your publisher callmanager server, go to start > programs > administration tools > services > verify the status for services "Cisco CDR Insert" and "Cisco CDR Analysis and Reporting Scheduler". If they are not "started", please restart them (just right-click on the service and select "restart").


If "Cisco CDR Insert" and "Cisco CDR Analysis and Reporting Scheduler" are running also in the subscriber servers, please stop them.


-------------------


>>>Verify service parameters in callmanager servers (publisher and subscriber).


--go to ccm admin > service > service parameters > select a callmanager server from the drop-down list > at "service" please select "Cisco CallManager" > click on "advanced" > verify that the following parameters are set to the correct values:


CDR Enabled Flag = True

CDR Log Calls with Zero Duration Flag = True

Call Diagnostics Enabled = True


***Repeat the same procedure for all callmanager servers in your cluster***


--Now go to ccm admin > service > service parameters > select a callmanager server from the drop-down list > at "service" please select "Cisco Data Base Layer Monitor" > verify that the following parameter is set to the correct value:


Max CDR Records = 1500000


***Repeat the same procedure for all callmanager servers in your cluster***


--Now go to ccm admin > system > enterprise parameters > verify that the following parameters are set to the correct values:


CDR File Time Interval (min) = 1

CDR Format = CDRs will be inserted into database

CDR UNC Path = \\\CDR

Local CDR Path = C:\Program Files\Cisco\CallDetail


***Repeat the same procedure for all callmanager servers in your cluster***


-------------------


>>>Please go to start > programs > administration tools > services and restart the following services after hours:


1) Restart service "Cisco database Layer Monitor" on publisher and subscriber servers.


2) Restart service "Cisco CDR Insert" on the publisher server.


3) Restart service "Cisco CDR Analysis and Reporting Scheduler" on the publisher server.


-------------------


>>>Run SQL querys:


In your publisher server, go to start > programs > SQL Server > Query Analyzer > SQL Server: (local) ; Select "windows authentication"; click on "OK" > select the "ART" database from the drop-down menu. Run the following queries (just copy and paste the following in the main window, then click on the "execute query" icon):


delete from Tbl_Load_History

delete from Tbl_Dump_PkID

delete from Tbl_Error_Id_Map

delete from Tbl_Billing_Data

delete from Tbl_Billing_Error

delete from Tbl_Dump_CallDetailRecord

delete from Tbl_Dump_CallDetailRecordDiagnostic


-------------------


Login into the CAR tool > go to the "system" menu > scheduler > CDR Load > Load CDR & CMR > by default, Time will be set at 00 Hr, 00 Min; Loading Interval = Every 24 hours; please change the "Duration" parameter to 120 min.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
UCBNOCWAN Tue, 12/18/2007 - 03:23
User Badges:

Please check the CCM version you are using & the SR release installed.

UCBNOCWAN Tue, 12/18/2007 - 03:46
User Badges:

Same issue with me too, we are running 4.1(3) SR3. ( you can check the SR version by going to "Help -> About CCM". you have to upgrade the SR to at least SR4. Another work-around is to run SQL queries directly from the database.

rodrigodiazmondelo Tue, 12/18/2007 - 04:55
User Badges:

Well , I try to upgrade the SR but only a question .

I can not use the SQL query because it shows me record until 26 October too.

Were you able to see logs at SQL server from any date range?

Correct Answer
jbarcena Tue, 12/18/2007 - 08:00
User Badges:
  • Red, 2250 points or more

This is a really really common issue, try the following this normally fixes the problem 95% of the times:


>>>Verify that "Cisco CDR Insert" and "Cisco CDR Analysis and Reporting Scheduler" services are running ONLY in the Publisher Call Manager:


in your publisher callmanager server, go to start > programs > administration tools > services > verify the status for services "Cisco CDR Insert" and "Cisco CDR Analysis and Reporting Scheduler". If they are not "started", please restart them (just right-click on the service and select "restart").


If "Cisco CDR Insert" and "Cisco CDR Analysis and Reporting Scheduler" are running also in the subscriber servers, please stop them.


-------------------


>>>Verify service parameters in callmanager servers (publisher and subscriber).


--go to ccm admin > service > service parameters > select a callmanager server from the drop-down list > at "service" please select "Cisco CallManager" > click on "advanced" > verify that the following parameters are set to the correct values:


CDR Enabled Flag = True

CDR Log Calls with Zero Duration Flag = True

Call Diagnostics Enabled = True


***Repeat the same procedure for all callmanager servers in your cluster***


--Now go to ccm admin > service > service parameters > select a callmanager server from the drop-down list > at "service" please select "Cisco Data Base Layer Monitor" > verify that the following parameter is set to the correct value:


Max CDR Records = 1500000


***Repeat the same procedure for all callmanager servers in your cluster***


--Now go to ccm admin > system > enterprise parameters > verify that the following parameters are set to the correct values:


CDR File Time Interval (min) = 1

CDR Format = CDRs will be inserted into database

CDR UNC Path = \\\CDR

Local CDR Path = C:\Program Files\Cisco\CallDetail


***Repeat the same procedure for all callmanager servers in your cluster***


-------------------


>>>Please go to start > programs > administration tools > services and restart the following services after hours:


1) Restart service "Cisco database Layer Monitor" on publisher and subscriber servers.


2) Restart service "Cisco CDR Insert" on the publisher server.


3) Restart service "Cisco CDR Analysis and Reporting Scheduler" on the publisher server.


-------------------


>>>Run SQL querys:


In your publisher server, go to start > programs > SQL Server > Query Analyzer > SQL Server: (local) ; Select "windows authentication"; click on "OK" > select the "ART" database from the drop-down menu. Run the following queries (just copy and paste the following in the main window, then click on the "execute query" icon):


delete from Tbl_Load_History

delete from Tbl_Dump_PkID

delete from Tbl_Error_Id_Map

delete from Tbl_Billing_Data

delete from Tbl_Billing_Error

delete from Tbl_Dump_CallDetailRecord

delete from Tbl_Dump_CallDetailRecordDiagnostic


-------------------


Login into the CAR tool > go to the "system" menu > scheduler > CDR Load > Load CDR & CMR > by default, Time will be set at 00 Hr, 00 Min; Loading Interval = Every 24 hours; please change the "Duration" parameter to 120 min.


Actions

This Discussion