Problem with ports in a certain VLAN

Answered Question
Dec 18th, 2007

Hi,

I have problems with ports in Vlan 138.

The ports are up and say there is something connected to them.

They are configured in the right vlan and are trunking correctly.

I have moved one of the devices to a different port configured with a different vlan and works fine.

Any help appreciated.

Thanks

Kev

I have this problem too.
0 votes
Correct Answer by Kevin Dorrell about 8 years 11 months ago

That is definitely your problem then. If the printers are in 10.130.138.0/24, then they will only work properly in VLAN 88, because the router will route traffic for that subnet to VLAN 88 only. Neither will they be able to talk through the router from VLAN 138 because the router does not have any presence on VLAN 138.

On VLAN 138, the only connectivity they will have is with other stuff of VLAN 138, and then only if configured in the same subnet.

If you want this to work, take the secondary address off VLAN 88, and put it as a primary address on an SVI for VLAN 138. Extend the rest of the VLAN 138 SVI config to look similar to that for VLAN 88, and do so for the other HSRP partner too.

Kevin Dorrell

Luxembourg

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
lgijssel Tue, 12/18/2007 - 05:23

Please explain a bit more about the nature of your problem.

Leo

kevinhobson2000 Tue, 12/18/2007 - 05:35

There is no layer 3 connectivity to some printers connected to fa ethernet ports on a 3560 switch. I cant even ping them i have done a show int on the relevant interfaces and everythint looks fine.

Thanks

Kev

Kevin Dorrell Tue, 12/18/2007 - 05:38

It sounds like they don't have a correct IP address. How are the IP addresses allocated: are they DHCP or static?

Do you have portfast configured on all your access ports? I still don't understand " ... and are trunking correctly .. ", both it might be a clue to the problem.

Kevin Dorrell

Luxembourg

lgijssel Tue, 12/18/2007 - 05:48

You should also check your vtp status. If this vlan138 is not correctly propagated through the network you may experience issues like this.

Perhaps you have used the command 'switchport trunk allowed-vlan' on some of your trunk ports? This command should contain vlan 138 to allow it on your trunks.

regards,

Leo

Kevin Dorrell Tue, 12/18/2007 - 05:35

I don't think I fully understand " ... and are trunking correctly ... ". Are these access ports or trunk ports you are talking about?

Could you post two show run int, one for a port that works and one for a port that doesn't, please? Are they on the same switch, for example?

Kevin Dorrell

Luxembourg

kevinhobson2000 Tue, 12/18/2007 - 05:54

This one works:

interface FastEthernet0/2

description VOICE or DATA VLAN

switchport trunk encapsulation dot1q

switchport trunk native vlan 88

switchport mode trunk

switchport voice vlan 176

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

priority-queue out

mls qos trust cos

auto qos voip trust

spanning-tree portfast trunk

end

This one doesnt:

interface FastEthernet0/19

description Printers

switchport access vlan 138

spanning-tree portfast

end

The Printer atached to the one that works now used to be connected to one of the ports that doesnt work.

Cheers

Kev

kevinhobson2000 Tue, 12/18/2007 - 05:58

Here is the config for the trunk interface:

interface FastEthernet0/24

description LES circuit

switchport trunk encapsulation dot1q

switchport mode trunk

speed 10

duplex full

end

Kevin Dorrell Tue, 12/18/2007 - 06:22

There is something I am missing here. I am really confused. Are you saying that you connect a printer to a trunk port that has native 88, and it works? And on an access port on VLAN 138 it doesn't?

Does VLAN 138 actually exist, and does it have a DHCP server in it? Can you ping the printer from the router in VLAN 138?

Kevin Dorrell

Luxembourg

kevinhobson2000 Tue, 12/18/2007 - 06:38

Kev,

Sorry

Let me explain the switch these printers are connected to are configured for data and voice ports.

The ones configured with access to Vlan 138 can not be pinged. The one connected to the Voice and Vlan port can be pinged you also see an entry for it in the ARP table on the L3 switch.

VLAN 138 exists on the switch.

Thanks

Kev

Kevin Dorrell Tue, 12/18/2007 - 06:45

When you do a show mac-address-table vlan 138 at the access switch, can you see the MAC address of the printer, and that of the L3 switch?

Same question at the layer-3 switch?

How are the IP addresses allocated, DHCP or static?

kevinhobson2000 Tue, 12/18/2007 - 06:58

Kev,

On the access switch i get:

Vlan Mac Address Type Ports

---- ----------- -------- -----

All 0100.0ccc.cccc STATIC CPU

All 0100.0ccc.cccd STATIC CPU

All 0180.c200.0000 STATIC CPU

All 0180.c200.0001 STATIC CPU

All 0180.c200.0002 STATIC CPU

All 0180.c200.0003 STATIC CPU

All 0180.c200.0004 STATIC CPU

All 0180.c200.0005 STATIC CPU

All 0180.c200.0006 STATIC CPU

All 0180.c200.0007 STATIC CPU

All 0180.c200.0008 STATIC CPU

All 0180.c200.0009 STATIC CPU

All 0180.c200.000a STATIC CPU

All 0180.c200.000b STATIC CPU

All 0180.c200.000c STATIC CPU

All 0180.c200.000d STATIC CPU

All 0180.c200.000e STATIC CPU

All 0180.c200.000f STATIC CPU

All 0180.c200.0010 STATIC CPU

All ffff.ffff.ffff STATIC CPU

138 0018.180f.b606 DYNAMIC Fa0/24

138 00e0.815d.5bb7 DYNAMIC Fa0/21

138 00e0.815f.7677 DYNAMIC Fa0/20

138 0800.2302.4adb DYNAMIC Fa0/19

On the L3 Switch i get:

vlan mac address type protocols port

-------+---------------+--------+---------------------+----------------

138 00e0.815d.5bb7 dynamic ip FastEthernet3/7

138 00e0.815f.7677 dynamic ip FastEthernet3/7

a-ford Tue, 12/18/2007 - 13:41

Am I correct to assume that your L3 switch attaches to the switch in question via f3/7?

What is the config of the SVI on your L3 switch? While logged into the L3 switch can you ping the SVI for vlan 138?

When you plug your printer into the voice/video port, we are assuming that the printer is inserting in Vlan 88. What IP is the printer getting when you can ping it and what VLAN does this address associate to?

kevinhobson2000 Wed, 12/19/2007 - 01:27

Hi,

That is correct.

There is no SVI for VLAN 138 on the L3 switch only for vlan 88.

Config below:

interface Vlan88

description Warehouse-VLAN

ip address 10.130.138.1 255.255.255.0 secondary

ip address 10.130.88.2 255.255.248.0

ip helper-address 10.130.0.53

ip helper-address 10.137.0.53

no ip redirects

standby 88 ip 10.130.88.1

standby 88 priority 20

standby 88 preempt

end

I am looking at this remotely and the person on site has informed me that 10.130.138.1 is the Default Gatway for the printers as i thought this was originally the problem. The printers are on statics from 10.130.138 - 214. Some more info below:

AmSWCI01#sh ip arp 10.130.138.213

Protocol Address Age (min) Hardware Addr Type Interface

Internet 10.130.138.213 0 00e0.815d.64b1 ARPA Vlan88

AmSWCI01#sh ip arp 10.130.138.214

Protocol Address Age (min) Hardware Addr Type Interface

Internet 10.130.138.214 126 00e0.815d.63cb ARPA Vlan88

These are connected to interfaces fa0/2 and fa/04:

Warehouse#sh mac-address-table | i 00e0.815d.64b1

88 00e0.815d.64b1 DYNAMIC Fa0/2

Warehouse#sh mac-address-table | i 00e0.815d.63cb

88 00e0.815d.63cb DYNAMIC Fa0/4

The mac addresses for the devices in Vlan 138 are listed below:

138 0018.180f.b606 DYNAMIC Fa0/24

138 00e0.815d.5bb7 DYNAMIC Fa0/21

138 00e0.815f.7677 DYNAMIC Fa0/20

138 0800.2302.4adb DYNAMIC Fa0/19

The other two i have been told are configured on FA 0/20 - 21.

interface FastEthernet0/20

description Printers

switchport access vlan 138

spanning-tree portfast

end

interface FastEthernet0/21

description Printers

switchport access vlan 138

spanning-tree portfast

end

Correct Answer
Kevin Dorrell Wed, 12/19/2007 - 01:41

That is definitely your problem then. If the printers are in 10.130.138.0/24, then they will only work properly in VLAN 88, because the router will route traffic for that subnet to VLAN 88 only. Neither will they be able to talk through the router from VLAN 138 because the router does not have any presence on VLAN 138.

On VLAN 138, the only connectivity they will have is with other stuff of VLAN 138, and then only if configured in the same subnet.

If you want this to work, take the secondary address off VLAN 88, and put it as a primary address on an SVI for VLAN 138. Extend the rest of the VLAN 138 SVI config to look similar to that for VLAN 88, and do so for the other HSRP partner too.

Kevin Dorrell

Luxembourg

kevinhobson2000 Wed, 12/19/2007 - 01:46

Yeah,

This was my original feeling but they assured me it had worked before.

Anyway thankyou for the help.

Cheers

Kev

Actions

This Discussion