PPPoE to Cisco 831 (Ethernet port)

Unanswered Question
Dec 18th, 2007

Hello folks !!!

I am tring to stabilish a PPPoE session over a ADSL line but i am facing problems with virtual-template interface.

- I has configured PPPoE without NAT.

- My router works like a DHCP server.

- The ethernet 0 (connected to LAN) has a local ip address

- The ethernet 1 ( connected to ISP provider) is configurated to negociate the ip address.

The problem is that I can see different PPP sessions (to different times of show ppp session all). It is cuased because the Virtual-Template interface (created automatically when the Dialer interface is created) is flapping as well.

I need some help to stabilish the session. Is there any other configuration at Virtual-Template interface ?

All is well configured but i don't know if there is any additonal set at virtual-template interface to not flapp the interface

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Paolo Bevilacqua Tue, 12/18/2007 - 10:22

Hi,

actually for a simple configuration, virtual-template is not necessary.

Just configure a dialer interface and tie it to pppoe-client command.

Hope this helps, please rate post if it does!

fabio.nunes Tue, 12/18/2007 - 11:08

Hi,

Yes I already did it but i am receiving the logs above.

%DIALER-6-UNBIND: Interface Vi1 unbound from profile Di1

Di1 DDR: Cannot place call, no dialer string set

Above is the currente interface configurations.

interface Ethernet0 (LAN interface)

ip address 10.27.0.1 255.255.255.0

ip virtual-reassembly

ip tcp adjust-mss 1452

no cdp enable

hold-queue 32 in

interface Ethernet1

description $WAN$ (ISP interface)

no ip address

ip virtual-reassembly

duplex auto

pppoe enable

pppoe-client dial-pool-number 1

no cdp enable

crypto map testmap

crypto ipsec df-bit clear

interface Dialer1

ip address negotiated

ip mtu 1492

encapsulation ppp

dialer pool 1

dialer wait-for-line-protocol 3

dialer-group 1

ppp authentication chap callin

ppp chap hostname [email protected]

ppp chap password 7 123456

How could I do to clear these logs ?

Paolo Bevilacqua Tue, 12/18/2007 - 11:49

Hi, your dialer might not go up at all, check with debug ppp negotiation and authentication.

fabio.nunes Tue, 12/18/2007 - 13:35

Hi !!!

I can see in the logs that the pppoe session is not been stabilished. There are these logs:

[log cut]

* Vi1 CHAP: I FAILURE id 1 len 43 msg is "Account password must be plain for chap"

[log cut]

* Vi1 PPP: Phase is terminated

* Dialer-6-UNBIND: Interface Vi1 unbound from profile Di1

[log cut]

What does it mean "Account password must be plain for chap" ?

fabio.nunes Wed, 12/19/2007 - 05:23

Hi !!!

Tks for help sir. I will check it with ISP.

The last question:

I would like to clarify the message sent from ISP's AAA server. Do you know the real sense os this message ? "Account password must be plain for CHAP".

I paste the debugging PPP negociation line bellow.

*Mar 2 01:25:11: Vi1 CHAP: I FAILURE id 1 len 43 msg is "Account password must be plain for CHAP"

I apreciate your help for this issue. We don't know if it should be handled by the ISP or by us. Anyway many thanks for the support and attencion.

Brgds.

Fabio Nunes

Paolo Bevilacqua Wed, 12/19/2007 - 10:14

Hi,

Really the error message doesn't tell me anything to me and you should clarify with ISP.

You can easily try if you have better luck with PAP as mentioned before. Just configure the usenrmae and password, you can remove altogether the "ppp authentication" statement.

Good luck!

Actions

This Discussion