VLAN configuration (network setup recommendation)

Unanswered Question
Dec 18th, 2007

Pls help,I need your suggestion to my new network setup specially if the VLAN and VTP is possible. I hve 2811 router and 3 switches.The first 3550 switch (all 48 ports)connected to 2811 via Fastethernet and the 2 cisco switch 2950 via cross cable cable or should i use VTP?. I have 140 users and 3 servers. Can i use a Vlan to separate the servers and the users? Any suggestion please.My purpose is to improve the performance of my network specially to my servers. thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (2 ratings)
Loading.
royalblues Tue, 12/18/2007 - 22:12

Create 3 vlans, one each for management, server and users on the 3550 L3 switch.

Create a corresponding SVI as well

Make it a VTP server and configure trunking to the 2960 switches

connect your servers and the routers to the 3550

Route your traffic to the 2811 either via static or dynamic routing

HTH

Narayan

iceman0813 Tue, 12/18/2007 - 22:42

PLease help me.

Hi royal blues,

Sir thanks for your immediate response. Sorry its my first time to implemnt VLAn, my i know why do i need 3 VLANS? Can you please check my config below,am i correct?

ex

------vlan 3 for my 2 servers(File and backup)

vlan 3

name servers

interface fastethernet 0/2

switchport mode access

switchport access vlan 3

vlan 3

interface fastethernet 0/3

switchport mode access

---vlan for my users

vlan 4

name users

interface fastethernet 0/2-0/46

switchport mode access

switchport access vlan 4

I will make a VTP server to my cisco 3550, right?

How about the trunking, i will use cross cable for my 2 switches 2950?

What do you mean SVI and how can route the traffic tot he 2811.

God Bless and thanks for your help.

Jon Marshall Tue, 12/18/2007 - 23:46

Hi

Management vlan (for switches) = 192.168.4.0/28 = vlan 2

Server vlan = 192.168.5.0/24 - vlan 3

User vlan = 192.168.6.0/24 - vlan 4

Point to point link from 3550 to 2811 router

192.168.7.0/30

On 3550

3550(config)# ip routing

3550(config)# vtp domain "domain name - you choose"

3550(config)# vtp mode server

Connect your 2950 switches to the 3550 switch.

On the ports that connect the switches

int fa0/24

switchport trunk encapsulatioin dot1q

switchport mode trunk

You need to do this on either end of the link connecting the switches together. Note the "switchport trunk encapsulation dot1q" command may not be available on the 2950. Don't worry, just enter "switchport mode trunk".

If you are using rj45's to connect switches together you should use a cross over.

On the 2950's

2950(config)# vtp domain "same name as you used on 3550"

2950(config)# vtp mode client

On the 3550 switch you need to create the vlans

3550(config)# vlan 2

3550(config-vlan)# mgmt_vlan

3550(config)# vlan 3

3550(config-vlan)# name server_vlan

3550(config)# vlan 4

3550(config-vlan)# name client_vlan

The layer SVI's are next

on the 3550 switch

int vlan 2

ip address 192.168.4.1 255.255.255.240

no shut

int vlan 3

ip address 192.168.5.1 255.255.255.0

no shut

int vlan 4

ip address 192.168.6.1 255.255.255.0

no shut

You then connect the router to the 3550 switch. On the port that connects the 3550 to the router

3550(config-if)# no switchport

3550(config-if)# ip address 192.168.7.1 255.255.255.252

On the interface on the 2811 that connects to the 3550 switch

2811(config-if)# ip address 192.168.7.2 255.255.255.252

On the 2950 switches create a layer 3 SVI for vlan 2 only - this is so you can telnet to these switches to manage them

2950(config)# int vlan 2

2950(config-if)# ip address 192.168.4.2 255.255.255.240

2950(config-if)# no shut

2950(config)# ip default-gateway 192.168.4.1

For the second 2950 just use 192.168.4.3 as the address for the vlan 2 interface.

Last the routing.

You don't say which image you have on the 3550 switch. You can do the routing either with static routing or if you have teh advanced image you can use a routing protocol such as EIGRP.

As it a small setup lets use static routing.

On the 3550

3550(config)# ip route 0.0.0.0 0.0.0.0 192.168.7.2

this is the default route and any traffic that is not for vlan 2, 3 or 4 will get forwarded to the 2811 router.

On the 2811 router

2811(config)# ip route 192.168.4.0 255.255.255.240 192.168.7.1

2811(config)# ip route 192.168.5.0 255.255.255.0 192.168.7.1

2811(config# ip route 192.168.6.0 255.255.255.0 192.168.7.1

These routes allow the 2811 router to forward any packets for your vlans to the 3550 switch.

*** Edit - one thing i forgot to mention. When you then allocate your servers, clients into their correct vlans you need to use the corresponding L3 SVI ip address as the default-gateway. So in the exmaple used above when you configure the addressing on the actual server the default-gateway would be set to 192.168.5.1. For user pc's it would be 192.168.6.1. ***

HTH

Jon

iceman0813 Thu, 12/20/2007 - 17:33

hi jon,

sorry to disturb you, can you please help me hw to implement your suggestion.

This is my current setup.

2811- 151.117.182.254 (connected to 3550 via fast ethernet

3550- 151.117.182.3 (vlan 1 only no config)

2650 1st -151.117.182.4 (Vlan 1 only no config)

2950 2nd -151.117.182.5 (VLAN 1 only no config)

Thanks in advance.

Merry xmass!!!!

Elmer

then i have 2 servers connected to 3550

file- 151.117.182.1

backup 151.117.182.2

Actions

This Discussion