CISCO 2600+Serial 0/0+ Unable to ping

Unanswered Question
Dec 19th, 2007

Hi i m configuring CISCO 2600 to connect Internet. Thats why I use windows hyper terminal to configure the router.

And thereafter,I can only ping e0/0. But I can't ping s0/0 from hyper terminal.

below is my #sh int s0/0 Output.

admin-5#sh int s0/0

Serial0/0 is up, line protocol is up

Hardware is PowerQUICC Serial

Internet address is 123.49.2.150/30

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation HDLC, loopback not set

Keepalive not set

Last input never, output 00:00:44, output hang never

Last clearing of "show interface" counters 02:01:29

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/1/32 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

Available Bandwidth 1158 kilobits/sec

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

219 packets output, 50435 bytes, 0 underruns

0 output errors, 0 collisions, 18 interface resets

0 output buffer failures, 0 output buffers swapped out

0 carrier transitions

DCD=up DSR=down DTR=up RTS=up CTS=up

------and here is my #sh run...

admin-5#sh run

Current configuration : 1048 bytes

!

version 12.2

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname admin-5

!

enable secret xxx

enable password xxxxx

!

ip subnet-zero

!

!

!

ip audit notify log

ip audit po max-events 100

!

!

!

voice call carrier capacity active

mta receive maximum-recipients 0

!

!

!

!

interface Ethernet0/0

ip address 192.168.110.150 255.255.255.252

ip nat inside

no keepalive

half-duplex

!

interface Serial0/0

ip address 123.x.x.150 255.255.255.252

no keepalive

!

interface Serial0/1

no ip address

no ip mroute-cache

shutdown

!

ip nat pool destiny 192.168.110.1 192.168.110.255 prefix-length 24

ip nat inside source list 7 pool destiny

ip classless

ip route 0.0.0.0 0.0.0.0 Serial0/0

no ip http server

!

!

access-list 7 permit any

!

snmp-server community public RO

snmp-server enable traps tty

call rsvp-sync

!

!

mgcp profile default

!

dial-peer cor custom

line con 0

line aux 0

line vty 0 4

password xxxxxx

login

!

!

end

admin-5#

......................

I don't know why i cant ping mysel. and thought something wrong in my configuration....

Can u plz help me

Thanks in advance

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Richard Burts Wed, 12/19/2007 - 07:36

I wonder why the serial interface is configured with no keepalive? With this configured the interface will show as up and up whether or not it is working. What happens if you enable keepalive? If it stays up with keepalive enabled then we need to look in certain directions about why ping is not working. But if you enable keepalive and the interface goes protocol down then we know that there is some problem with the connection and that is why ping fails.

The question from Dandy about whether you can ping the router at the other end is another way to get at the same issue - is the link really working?

Dandy

That is an interesting link. But I wonder why you sent a link about problems with Frame Relay when this interface is clearly configured to use the default encapsulation of HDLC (and mapping is not an issue with HDLC)?

HTH

Rick

Danilo Dy Wed, 12/19/2007 - 08:01

Hi Rick,

Because it mentioned HDLC and also it says that the router in the other end will reply to the ping. Thats why I ask if he can ping the router in the other end.

"Pings to your own interface address are successful on point-to-point subinterfaces or high-level data link control (HDLC) links because the router on the other side of the link returns the ICMP echo and echo reply packets."

Regards,

Dandy

Richard Burts Wed, 12/19/2007 - 08:10

Dandy

Thanks for the clarification. I missed the reference to HDLC in the link. The explanation is quite correct that ping on a point to point link is sent over the link (received by the remote router and forwarded back over the link by the remote router) and the ping response is also sent over the link (and received and forwarded by the remote router). The result is that the ping to your own address makes 4 trips over the link while ping to the remote address makes 2 trips over the link.

I agree that your question about whether he can ping the remote router is a key step in investigating this problem.

HTH

rick

Danilo Dy Wed, 12/19/2007 - 08:14

Hi Rick,

Thanks :)

The "no keepalive" that you mentioned in the interface may be a problem also. But I'm not sure if with it and the router in the other end is down (or NTU), his router interface status will still show up/up - I haven't tried or experienced it.

Regards,

Dandy

Richard Burts Wed, 12/19/2007 - 08:21

Dandy

With HDLC a router sends a keepalive message and inside that keepalive message is a field (a sequence number) that the remote router should save and send back in its own keepalive. So if this router is working and the remote router is down, then the sequence number will not be returned and the keepalive will fail, and the interface will go to protocol down state. I have tested this many times and the HDLC keepalive is quite reliable about assuring that there is 2 way traffic over the link.

HTH

Rick

Danilo Dy Wed, 12/19/2007 - 08:26

Hi Rick,

Thanks for the info. I was thinking to mention it in my first post as reply to his question but since I can't be too sure I didn't mentioned it :).

Regards,

Dandy

Actions

This Discussion