Calls getting dropped

Unanswered Question
Dec 19th, 2007


My scenario is like this:

IP Phone ---> Call Manager---->h323 gateway--->Avaya -----> Avaya phone.

I have created two device pools, DP-1 and DP-2 and assigned separate regions to these Device Pools. The codec between these regions has been configured as G.729. One hardware transcoder has also been created in the router and assigned to a MRGL which both DP's are using. IP Phone has been assigned to DP-1, and H.323 gateway has been assigned to DP-2. So the calls through this gateway to Avaya will be G.729 codec. Avaya has been configured to make the calls to the H323 gateway as G.729.

Whenever I am making a call to Avaya, I am able to get the ring from Avaya, when the receiver is picked up I am not able to hear anything. This is same when both side makes a call.

The IP reachability is there between all the devices. I have tried making the MTP required checked and unchecked under the gateway configuration, but the same result.

In the debug voip ccapi inout I am getting an error which is attached herewith.

The error code mentioned is 47 which is no resource. I have also checked by changing the codec values on both the ends.

Can anyone tell what could be the problem?



I have this problem too.
1 vote
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Suresh Subramanian Thu, 01/16/2014 - 02:44

Disconnect Cause=47 is indicating issue is media negotiating like Transcoder, MTP & Codec negotiation.

Crosscheck the incoming & outgoing dial-peers for matching codec & voice class codec configurations. saw outbound dial-peer 40 matched but no logs to show matching inbound dial-peer.

CUCM has an option for "Wait for far end H245 TCS" on CUCM which is checked by default. Try to uncheck it and test the behaviour please.

Please collect detailed ccm traces & debug voice ccapi inout, debug h225 asn1 & debug h245 asn1.

what is the connection type from GW to PBX? PRI or IP connection? Please post your GW config also.

Please rate all the useful posts

maputogarnett Wed, 01/15/2014 - 23:45


I had this problem but solved it already.

Myproblem was in the Region. I didn´t set the local codec.

Now its working. Try to re-check the codecs

Hermanus Janse ... Thu, 01/16/2014 - 02:47

Yes as Hugo say the Codec is very important as well as you need to make sure you have a media resource group assigned to the trunk between the 2 pabxs.


This Discussion