Still One way audio

Unanswered Question
Dec 20th, 2007

Hello all,

I have been working on a one way audio issue for sometime now and the problems still persist. What I have discovered is that, when there is a voice call across the link, all ping tests are dropped. I have applied QoS on the link but the same problem persists. The best ping result is 1700ms when there is a single call. I have used several codecs to change the compression rate but the same problem."ONE WAY AUDIO". Routing is fine.

attached is the configs. Please let me know what you think.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
davetucker Thu, 12/20/2007 - 02:06

Hi,

Try adding the following to the config

"voice-class codec 10" command under each voip dial-peer.

"h323-gateway voip bind srcaddr x.x.x.x" on each Ethernet interface where x.x.x.x is the Voice vLAN IP Address.

Let me know if this helps.

Regards,

Dave

jkofosu Thu, 12/20/2007 - 02:40

Hello Dave,

Thanks for the post. I have tried the voice-class codec 10 on all the dial-peers but the issue is the same. We are using FXS connected directly to the back of the router so there are no vlans configured. Hope to hear soon.

davetucker Thu, 12/20/2007 - 03:07

Hi,

!

interface FastEthernet0/0

ip address 10.5.0.254 255.255.255.0 secondary

ip address 172.21.57.253 255.255.255.0 secondary

ip address 10.254.254.10 255.255.255.0

h323-gateway voip bind srcaddr 10.254.254.10

service-policy output VOICE-POLICY

duplex auto

speed auto

!

Try adding the H323 binding command to the IP address that is being targetted by the dial-peers. If this doesn't work please let me know and I'll need the results of some debugs...

Regards

Dave

jkofosu Thu, 12/20/2007 - 05:29

Hello Dave,

Thanks again. I have done this but the problem persists.

Rgds.

davetucker Thu, 12/20/2007 - 06:30

Hi,

Can you get me the debug outputs of the 2 routers on a call from A to B.

deb voip dialpeer

deb voip rtp

Also what speed is the link between the 2 routers and what technology? Frame, ATM, Ethernet etc...

davetucker Thu, 12/20/2007 - 08:05

You should also consider using Class Based Packet Marking in your QoS Policy.

!

policy-map VOICE-POLICY

class voice-traffic

priority 160

set ip dscp ef

class voice-signal

bandwidth 16

set ip dscp cs3

class class-default

set ip dscp 0

fair-queue

!

Although the current policy allows 160 of priority bandwidth in times of congestion, the packet is not marked with any dscp value.

vinay_verma80 Tue, 01/01/2008 - 21:36

Hi

use the policy map

interface Loopback323

description ---

ip address " Ip of loopback address"

h323-gateway voip bind srcaddr " ip address of loopback "

use policy map

policy-map VOICE-POLICY

class voice-traffic

priority 160<<<<<<<<< depending who many port around 25k to 27k per FXS port

( for marking the RT and signaling both As ef use " set-dscp-transmit ef")

class class-default

fair-queue

random drop

!

class-map match-all voice-traffic

match Match access-group name RT

Extended IP access list DSCP-OUT-RT

10 permit ip host "ip add of loopback" any

20 deny ip any any

Also what is ur interface speed (configured on router ) and the actually speed , if if is leas than 764k u also have to use fragmentation

also remember QOS is end to end

after these policy see if ur packet are getting marked or not

Regards

canowlin Wed, 01/02/2008 - 16:31

try something simple like this

!

voice call send-alert

voice rtp send-recv

!

voice service voip

h323

no h225 timeout keepalive

modem passthrough nse codec g711ulaw

voice class h323 1

h225 timeout tcp establish 3

!

interface FastEthernet0/0

description connection Voice Vlan

ip address 10.15.53.1 255.255.255.0

duplex full

speed 100

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.15.53.1

your pings could be a circuit issue.... which would probably cause quality issues. did you look at your interfaces?

Actions

This Discussion