What If .. re EtherChannel and layer 2 VLAN trunks

Unanswered Question

I am wondering what would occur if two 3750G switch stacks were connected together via two pairs of SFP ports.

The ports were configured identically as VLAN Trunks with the same vlans allowed on all trunks.

In addition if the ports are made members of a single Etherchannel group 1 what happens if one port of the four has the "channel-group 1 mode on" command missing from its config.

Would the switches see this as two links instead of the one logical etherchannel group.

Would this cause the vlans allowed on the trunk to flap. ( Loop Condition)

I encountered this scenario recently when

one swith lost power and on reboot its running cfg had not been saved this caused the one port to not have the channel mode on conmmand.

I believe this may have caused a loop condition but I am not 100% sure.

Anyone know for sure ?

Relevant config info

port-channel load-balance src-dst-mac

no file verify auto

!

spanning-tree mode pvst

spanning-tree portfast bpduguard default

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

spanning-tree uplinkfast

.......

interface Port-channel1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,291,297,300-302,993

switchport mode trunk

..........

Misconfigured port######

interface GigabitEthernet1/0/25

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,291,297,300-302,993

switchport mode trunk

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

queue-set 2

mls qos trust cos

auto qos voip trust

########

Three correctly configured ports######

interface GigabitEthernet2/0/25

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,291,297,300-302,993

switchport mode trunk

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

queue-set 2

mls qos trust cos

auto qos voip trust

channel-group 1 mode on

##################################

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Edison Ortiz Fri, 12/21/2007 - 14:29

The switchports would go into err-disabled. It's the same concept as plugging a copper cable from F0/1 to F0/2 on the same switch.

The stack cable converts 2 switches into one logical hardware.

The wording of you reply does not make it clear which ports of the four ports involved would go err-disabled. The misconfigured port ? The misconfigured port plus the one that it is directly "fiber connected" to ? or all four.

This flies in the face of what I encountered.

The two directly connected pairs of SFP ports behaved as follows:

The properly configured directly connected pair stayed up.

The pair with one end port improperly configured did not participate in etherchannel but also stayed up.

The vlans on the trunks flapped.

I don't understand why ?

Actions

This Discussion