bgp and default routes into EIGRP

Unanswered Question
Dec 20th, 2007
User Badges:
  • Bronze, 100 points or more

Working more on my lab. Running BGP across frame MPLS (two different providers) and EIGRP on internal network; distributing BGP into EIGRP but not the other way around.


Works okay except that now, I'd like to have each router advertise itself with equal metrics into EIGRP as the default gateway so that traffic not identified by my route-map will simply load balance between the two MPLS nets.


I first put a static route on each router and then added the redistribute static on eigrp config. That works.


BUT...I don't really want to put a static default route on the routers because in our real world (we don't use Eigrp but we do use BGP) the ISP's told us not to put default routes on our routers but instead to use "network 0.0.0.0" under the BGP config on the routers at the central site.


Now, when I look at my real life config it includes:

Router BGP 101

Network 0.0.0.0

And, when I look at the branch office router routing tables, they contain:

B* 0.0.0.0/0 [20/0] via x.x.x.x, 5w1d


So, how would I get that one route into EIGRP? My config already contains the command:


Router EIGRP 32

redistribute bgp metric...


But even though all my other BGP routes go in, the learned default route does not go in. I have read something that said I'd need to use default-information orginate (always) BUT every time I read about that, it's always linked to the use of BGP with OSPF. Does it apply to eigrp as well?


I've also read I can use a route map on the redistribute command and permit 0.0.0.0. But all the examples I've seen are aimed at permitting 0.0.0.0 and...I guess the implicit deny keeps all the others from being learned? I need to know about everything. So would a route map permitting any any let all my routes including the default in?


Thanks!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
royalblues Thu, 12/20/2007 - 08:24
User Badges:
  • Green, 3000 points or more

can you post your configs..


you should see the default route in the EIGRP table if your redistibution is configured properly


Narayan

suelange Thu, 12/20/2007 - 08:57
User Badges:
  • Bronze, 100 points or more

well that's the problem.


In real life I can't just go playing with the configs so they don't have EIGRP at all.


In the lab I don't have a real frame relay switch only an emmulation unit made with an old router and some cross over t1's. This unit won't simmulate what really happens in the frame relay cloud. Thus the NETWORK 0.0.0.0 statement has no effect. So I'm forced to use static routes there.


So I don't have a config to post because I can't really get the frame to carry the BGP routes all the way across. But I can see in the "real world" that the default route *is* there in the routing table with a "B*" designation.


IF I read your email correctly, the fact that I am redistributing BGP into EIGRP *should* be expected to put all BGP routes into the EIGRP table...even the default route?

royalblues Thu, 12/20/2007 - 09:08
User Badges:
  • Green, 3000 points or more

Yes it redistributes the default as well and frame-relay should not be any problem either. it is just another medium of transport


have a look at the output below

R1 --bgp-- R2 --EIGRP--R4


R1


interface serial 2/0

ip address 10.10.10.1 255.255.255.0

clock rate 6400


router bgp 100

neighbor 10.10.10.2 remote-as 200

network 0.0.0.0


ip route 0.0.0.0 0.0.0.0 null 0



R1#sh ip bgp

BGP table version is 2, local router ID is 10.10.10.1

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete


Network Next Hop Metric LocPrf Weight Path

*> 0.0.0.0 0.0.0.0 0 32768 i

R1#



R2


interface serial 2/0

ip address 10.10.10.2 255.255.255.0


interface serial 2/1

ip address 20.20.20.1 255.255.255.0

clock rate 64000


router bgp 200

neighbor 10.10.10.1 remote-as 100


router eigrp 100

network 20.20.20.0 0.0.0.255

redistribute bgp 200 metric 100 10 255 1 1500

no auto-summary


R2#sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route


Gateway of last resort is 10.10.10.1 to network 0.0.0.0


20.0.0.0/24 is subnetted, 1 subnets

C 20.20.20.0 is directly connected, Serial2/1

10.0.0.0/24 is subnetted, 1 subnets

C 10.10.10.0 is directly connected, Serial2/0

B* 0.0.0.0/0 [20/0] via 10.10.10.1, 00:06:09

R2#


R4


interface serial 2/0

ip address 20.20.20.2 255.255.255.0


router eigrp 100

network 20.20.20.0 0.0.0.255

no auto-summary


R4#sh ip eigrp top

R4#sh ip eigrp topology

IP-EIGRP Topology Table for AS(100)/ID(20.20.20.2)


Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

r - reply Status, s - sia Status


P 0.0.0.0/0, 1 successors, FD is 26114560, tag is 100

via 20.20.20.1 (26114560/25602560), Serial2/0

P 20.20.20.0/24, 1 successors, FD is 2169856

via Connected, Serial2/0



HTH

Narayan

suelange Thu, 12/20/2007 - 10:54
User Badges:
  • Bronze, 100 points or more

Fantastic. Thanks so much!

royalblues Thu, 12/20/2007 - 11:28
User Badges:
  • Green, 3000 points or more

glad that helped and thanks for the rating


Narayan

Actions

This Discussion