Device Discovery Problem

Answered Question
Dec 20th, 2007

Hey Everyone -

I am running LMS 3.0 and having some trouble getting new devices added to my system. In the inital setup I was able to successfully add 3 devices from one range of IP addresses. I just added a few more IP addresses, made sure they all had public ro / private rw strings, and ran the device discovery. They are not being discovered though. Does anyone have any ideas as to why the original 3 devices were picked up right away through device discovery, but now I can't seem to get it to recognize anything else?

Also, the devices are 2 x 2950 and 1 x 3560 switches. I have 3 of the same devices already setup.

Thanks in advance for the help!

I have this problem too.
0 votes
Correct Answer by Joe Clarke about 8 years 11 months ago

Either add them as seed devices in Campus Manager > Admin > Device Discovery > Discovery Settings or make sure that CDP reaches from your current three devices to these new devices.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Joe Clarke Thu, 12/20/2007 - 09:37

Device Discovery requires CDP, ILMI, or ELMI to find neighbors. If you do not have those protocols running between your seed devices (including those already in DCR) and these new devices, then discovery will not find them.

If CDP is running, you can enable devdiscovery debugging under Campus Manager > Admin > Debugging Options > Device Discovery, re-run the discovery, and the discovery.log will have more information.

whitlowdustin Thu, 12/20/2007 - 09:51

CDP is running. I just enabled devdiscovery, re-ran the discovery, and have attached the output of the log.

Do you think this might have something to do with the IOS on the other switches as well?

Attachment: 
Joe Clarke Thu, 12/20/2007 - 09:56

According to this, there are three seed devices, 10.0.07, 10.0.0.6, and 10.0.0.8. Each device on;y has each other as a CDP neighbor, so there are no other devices for discovery to find. Your missing devices must be neighbors of one of these three devices for discovery to find them.

whitlowdustin Thu, 12/20/2007 - 10:01

The 3 devices already in LMS are all in the same physical location. The other 3 devices I am trying to add are on the same network, but in different physical locations...as in, a completely different state in the USA.

10.0.32.2 & 10.0.32.3 are neighbors.

192.168.16.2 is a single switch.

What do I need to do to get them added?

Correct Answer
Joe Clarke Thu, 12/20/2007 - 10:11

Either add them as seed devices in Campus Manager > Admin > Device Discovery > Discovery Settings or make sure that CDP reaches from your current three devices to these new devices.

whitlowdustin Thu, 12/20/2007 - 10:14

I have all the IP Ranges set in Discovery Settings. To add the devices as a seed device do I just need to upload a text file with each device's IP Address in it?

Joe Clarke Thu, 12/20/2007 - 10:17

No, just click on the Configure button for seed devices, and type in an address or addresses.

Actions

This Discussion