inter vlan multicasting on a 1811 router

Unanswered Question

I have a multicast source (a server) on 1 vlan and clients that need to see this traffic on 2 other vlans on the same router, but multicast doesnt seem to be routed to the client vlans. I have ip multicast enabled globally and IP PIM enabled on each vlan interface. The IOS is advanced enterprise 12.4(15)T.

Thanks in advance fro your help!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jon Marshall Fri, 12/14/2007 - 03:31

Mike

What is the TTL of the multicast source. It may be that the TTL is not high enough to traverse the router.

Jon

Jon Marshall Thu, 12/20/2007 - 13:39

Mike

Yes, that should do it :)

Can you post output of

1) sh ip mroute

2) sh ip igmp membership

3) the mullticast address of the group

Jon

Edison Ortiz Thu, 12/20/2007 - 15:04

You've decided to configure the interface as sparse mode, you need a RP.

You can configure this same router to be the RP.

ip pim rp-address [ip of interface with pim enable]

Edison Ortiz Thu, 12/20/2007 - 17:22

Your router multicast configuration looks fine. Your OIL (Outgoing Interface List) from Multicast group 239.192.0.1 is pointing to the correct Vlan.

Are you able to ping 239.192.0.1 from the router ? Are you able to ping 239.192.0.1 from the receiver ?

If both answers are Yes, then I recommend looking closely to the application.

If both answers are No, then you can switch from sparse mode to dense mode and have multicast flood/prune behavior.

Are the end device(s) directly connected to this router (both source and receiver) or you have other switches in between ?

Ive been doing this testing with the sender and receiver directly connected to the router ports. pinging the multcast group address from the router does appear at the receiver. pinging from the receiver to the multicast group address did not appear at the sender.

Now im really confused!

Im willing to go with thte dense mode option - could you confirm what comands i enter on the interfaces to achieve this? I guess i wont need to point to router to an rp anymore?

Cheers

...and thanks for your help with this!

Mike

Edison Ortiz Thu, 12/20/2007 - 21:07

replace ip pim sparse with ip pim dense. Leave the RP in there, it won't be used in dense mode, but it won't hurt having it there if you decide to go back to sparse mode.

Hi there

I couldn't get this going with dense mode either. But I've found that if I disable snooping on the router the multicasts so start appearing on the target vlans. So im happy with this as I can let the LAN switches on the destination vlan deal with snooping (this works as we'd expect). Thanks for your help with this!

Actions

This Discussion