cisco 877 adsl - slow internet browsing

Answered Question
Dec 20th, 2007


after a adsl speed upgrade to 21Mbps (only get 17...)the router update was neeeded so ...

i've one cisco 877 that replaced a 8mbits usrobotics router, the problem is that all people are complaining about the speed (or lack of)...

in attach are the output of the runing config and sh dsl interface atm 0, and btw is normal to have Capacity Used: 100% 100%? and why?



I have this problem too.
0 votes
Correct Answer by Paolo Bevilacqua about 8 years 8 months ago

Hi, first of all the correct IP mtu under dialer0 should be 1492, not 1452. Consequently, adjust-mms should be 145, not 1412.

Then please send output of show interface atm0 at the time the access is slow.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Paolo Bevilacqua Fri, 12/21/2007 - 02:58


100% means that you are using all the bandwidth that is available with the ADSL technology.

Try upgrading ADSL firmware:

The one you want is 3.0.33 and there is a docfile that explains how to install.

Note, if users complain, install PRTG, monitor the the ADSL interface and check which actual traffic amount is being used. If it is a lot, it's normal that it goes slow.

Hope this helps, please rate post if it does!

praecedo6 Fri, 12/21/2007 - 05:37

Hi p.bevilacqua,

Thanks for your help and time,

it was what i thought, but I only find strange that its is 100% on both download and upload, I was thinking that the upload could be full, because of the 640k limits but the download should be less than 100% full( should be slow anyway because of the full uplink but the Capacity Used should reflect this).

I'll try to upgrade the firmware to the one you suggest, can I do any other debug to access this problem besides monitoring the link?

Before this new cisco (16mbps) they had 8mbps (usrobotics) and it was not so slow as now, that what bothers me, is that the link occupation I guess cannot be worst than before for the same usage, do you have any thoughts on this?

Regards and thanks once again,


Paolo Bevilacqua Fri, 12/21/2007 - 07:20

Please go ahead first with the FW upgrade.

Capacity indicate how much bandwidth is allocated in the ADSL standard, not how much traffic is being sent.

Only in case of further problems you may need to run debugs or monitor the link.

As an appreciation to those providing answers, please rate useful posts using the scrollbox below!

praecedo6 Tue, 12/25/2007 - 12:24

i did the fw upgrade as you suggest, now i have 100% 86% (?), but i have yet to confirm that its better in terms of user experience, nevertheless i put prtg working so tomorrow i'll have some other information

thanks once again


praecedo6 Mon, 01/21/2008 - 02:44

hi again,

on the router end the link is occupied by 20% but http browsing is slow eventhough i can download a file from a ftp server quicky.

firewall issues?



Paolo Bevilacqua Mon, 01/21/2008 - 04:15

Do this:

int dialer1

no ip mtu 1452

then from exec:

show ip route, check IP for next hop to

do ping df-bit size 1500

if it fails, decrease the size one byte at time, until it succeeds. Place the found MTU under dialer1, but if it is 1500 do not place anything.

If less than 1500 also place

Hope this helps, please rate post if it does!

praecedo6 Sun, 02/10/2008 - 16:33


sorry for the short delay...

anyway, the ip tcp adjust-mss didn't solve my problem

any other thought?



praecedo6 Thu, 02/21/2008 - 04:36


that was already in the configuration,

in the morning or late when everybody leave the browsing speed is ok but on "work hours" for e.g. it takes 4 or 5 seconds to open the initial page

does anyone have a clue on whats causing this problem?



Correct Answer
Paolo Bevilacqua Thu, 02/21/2008 - 10:23

Hi, first of all the correct IP mtu under dialer0 should be 1492, not 1452. Consequently, adjust-mms should be 145, not 1412.

Then please send output of show interface atm0 at the time the access is slow.

praecedo6 Fri, 02/22/2008 - 09:03

ok done.

if i try to download something from my isp, like fedora, the download speed is ~1,5 Mb/s but the browsing is slow 7 seconds to open google?



sh a int atm0

ATM0 is up, line protocol is up

Hardware is MPC ATMSAR (with Alcatel ADSL Module)

MTU 4470 bytes, sub MTU 4470, BW 637 Kbit, DLY 570 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ATM, loopback not set

Encapsulation(s): AAL5 AAL2, PVC mode

10 maximum active VCs, 1024 VCs per VP, 1 current VCCs

VC Auto Creation Disabled.

VC idle disconnect time: 300 seconds

Last input 00:00:27, output 00:00:00, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: Per VC Queueing

5 minute input rate 3000 bits/sec, 4 packets/sec

5 minute output rate 4000 bits/sec, 3 packets/sec

147 packets input, 32372 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

180 packets output, 68145 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

praecedo6 Thu, 04/10/2008 - 08:50

hi again,

after doing that change, i save it and restarted the router, i didn't see any improvements, i call the isp support, that after some tests on their side, told me nothing was wrong, the next day things start working fine and i had no more complaints from the end users. (Miraculous  )

and why should cisco for this basic setup didn't adapt well and not self configured this values, with drayteks (and others) this basic setup is automatically done, things just work, i understand that for some special cases adjustments have to be made and cisco has this possibility but in my case….

Any thoughts on this?

Either way,thanks!




This Discussion