adsm not working

Unanswered Question
Dec 21st, 2007


I struggling to get adsm to work, i have a asa 5520.

I have enabled http server in all contexts, I have set the ip range that has access to the asa via http. below are the settings:

In each context i have:

no asdm history enable

http server enable

http x.x.x.x cptint

and in the system i have:

asdm image disk0:/asdm-507.bin

no asdm history enable

I have recreated the cryto key as well. And i have checked the log files and the acl's are not blocking me. The error i get when i try to go to the website is:

404 Not Found

The requested URL /admin/public/index.html was not found on this server.

If anyone can help PLEASE let me know.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Danilo Dy Mon, 12/24/2007 - 09:09


Have you tried entering the complete URL without the "/public/" ? i.e. https://ip_address/admin/index.html

If it automatically goes to the page with "/public/" again, try using different computer.

If you have a maintenance, please log a case with Cisco TAC.



bluedrake Wed, 12/26/2007 - 23:22

I tried this from another machine and the same result, i have also tried the surgested url above and got no result....

bluedrake Thu, 12/27/2007 - 01:45

Good day all

Just an update, looks like my asdm software is out of date for the software version of my asa... will let you know if this solves it once i update it.

j.baumgardner Fri, 12/16/2011 - 10:40

Old post, but I found a solid resolution.

Whilst recovering and ASA from a customer, I had restored the default settings.

After I upgraded the ASA and ASDM software a while back, apparently I had accidentally left the old ASDM software on there as well.

When I performed the "config factory-defaults" it had selected the older, incompatible, ASDM.

The fix:

Make sure you have a compatible version of the ASDM and specify that in the startup config, as the directory structure is different via https.

supun1989 Tue, 08/09/2016 - 23:19

remove ASDM image from your flash & then upload new one. Try https://(ip address)


This Discussion