"no frame-relay inverse-arp" doesn't work

Unanswered Question
Dec 22nd, 2007

Hello!

Please, help me with frame-relay dymanic mapping. I cannot clean out dynamic from the output:

RackYR3#sh fram map

Serial1/0:0 (up): ip 132.1.0.1 dlci 301(0x12D,0x48D0), static,

CISCO, status defined, active

Serial1/0:0 (up): ip 33.5.0.15 dlci 707(0x2C3,0xB030), dynamic,

broadcast,

CISCO, status defined, active

Interface configuration:

interface Serial1/0:0

ip address 132.1.0.3 255.255.255.0

encapsulation frame-relay

frame-relay map ip 132.1.0.1 301

no frame-relay inverse-arp IP 707

I tried "shut/no shut" interface, router reload. Nothing help.

Have you any indeas?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (2 ratings)
Loading.
Edison Ortiz Sat, 12/22/2007 - 11:52

Try disabling inverse-arp on the router holding the 33.5.0.15 IP address.

If that doesn't work, try disabling inverse-arp in all DLCIs not just DLCI 707 on both routers.

Belova.Irina Sat, 12/22/2007 - 12:49

Thank you, Edison.

I sure I won't see dynamic entries if I disable inverse-arp on both routers.

How can I additionaly "delete" this dynamic mapping when I have no access to the other router?

Edison Ortiz Sat, 12/22/2007 - 14:57

Your router sends an ARP request to the remote router while remote router responds with an ARP reply.

The request can't be disabled with no frame-relay inverse-arp, it only disables the reply.

On this case, the remote router needs to stop responding to ARP request, hence in a proper configuration, both routers must have inverse-arp disabled if you don't want dynamic mappings.

Belova.Irina Sat, 12/22/2007 - 23:38

I wonder why documentation says just "no frame-relay inverse-arp protocol dlci" = "Disables Frame Relay Inverse ARP for a specific protocol and DLCI pair."

Nothing about request/reply!

Then, Edison, thank you very much, I have inverstigated the issue, and it seems to me the opposite is true. I mean "no frame-relay inverse-arp protocol dlci" disables inarp requests on the router. But when the router gets a request, it replies to it anyway. I saw it in "debug frame-relay packet".

Please, check me and fix me if I wrong.

Edison Ortiz Sun, 12/23/2007 - 09:15

It's the definition of inverse ARP.

What does regular ARP do? It sends requests to devices on its segment.

What does inverse ARP do? It sends replies to ARP requests.

You are disabling inverse ARP (arp replies), not just ARP (arp requests).

What you saw, it exactly proves my point. If you have a router without no frame-relay inverse-arp, it will request and reply to ARP while if you have a router with no frame-relay inverse-arp, it will only request but not reply to it.

Your remote router is sending dynamic entries to your local router because it's replying and requesting ARP. I'm sure the remote router doesn't have any dynamic entries from your local router because you have frame-relay inarp disabled.

Paolo Bevilacqua Sun, 12/23/2007 - 10:28

Well, yes and no :)

ARP and Inverse ARP are the same protocol. Inverse doesn't mean "replies only", instead it means, tell me the L3 address, as I know the L2 one already.

To do so, inverse ARP adds two "types" of request and reply:

http://tools.ietf.org/html/rfc2390

Then, the semantic of the cisco implementation can be confusing. Say "no" to a protocol, disables both request and replies, or replies only? The answer varies by protocol!

At the end, to be practical one can take a shortcut like I always recommend to do: use only point-to-point subinterfaces with FR, and say goodbye to inARP and a ton of other issues!

Edison Ortiz Sat, 12/29/2007 - 15:29

Cool tidbit, Paolo. Thanks for your contribution to this thread. Happy Holidays !

Paolo Bevilacqua Sat, 12/29/2007 - 15:49

Hi, that was just a professorial way to say "I don't really know why isn't working" :)

Happy Holidays to you Edison!

vinay_verma80 Sun, 12/30/2007 - 11:29

Hi,

for frame relay their is 2 concept

1 query

2 reply

U can stop the generation of the query with the " no frame relay inverse-arp" command . but U can not stop the reply for any arp query

I think that the other end is sending u a inv-arp query which ur local router is replying and so updating its local mapping table .

try to disable the query on the other (remote) side of the router ( and clear mapping)

{ Their is lots of confusion in b/w "inverse-arp" and "arp"

I use to remember these as "their is no concept of arp in frame relay as switch always send the query and the router always send the reply

so their is no use of the command

"[no] frame-relay arp" which u will find in lots of books )

regards

Actions

This Discussion