RME problem in LMS 2.6

Unanswered Question
Dec 24th, 2007
User Badges:

I have a LMS 2.6 with all the applications installed. RME is not functioning properly. to explain in detail,

In the device Management of RME , I am able to see all the devices, but when I tried to do a inventory collection for the devices, the job is failed, saying that the device type is not supported, and credential verification job also fails, eventhough credentials are correct.

when I tried sync archive, I am not able to select the devices at all, eventhough the deivces were available.


I tried deleting all devices and readd, but it didnt work. then I tried to reintialize the RME db using the command


dbRestoreOrig.pl dsn=rmeng dmprefix=RME


which I saw in another thread, but it also didnot help me.


Please throw some light on my problem


regards

sathappan

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Joe Clarke Tue, 12/25/2007 - 00:36
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

I suspect a device package problem. Please post the IC_Server.log and/or the dcmaclient.log.

Joe Clarke Tue, 12/25/2007 - 00:53
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Looks like you had a database access problem earlier, but the dbRestoreOrig.pl took care of that. Now, you have a package problem and an SNMP credential problem. It looks like you're missing the SharedInventoryGenericSNMP package. There must be SharedInventoryGenericSNMP.zip files under NMSROOT/MDC/tomcat/webapps/rme/WEB-INF/lib/pkgs and under NMSROOT/classpath/com/cisco/nm/xms/psu/pkgs/rme. The two files must be identical. From what I can tell, you're also missing SharedCdaIOS.zip, SharedInventoryCSS.zip, SharedConfigNegatSSRule.zip, SharedPollerCatL2L3.zip, SharedPollerGeneric.zip, SharedPollerCatSwitch.zip, SharedInventoryWLSE.zip, and the list goes on.


This means your RME installation (at the very least) is bad. Most likely, it is unrecoverably bad. You will need to uninstall RME, then reinstall and repatch it. Before doing that, you must set the TEMP and TMP environment variables to something short like C:\WINDOWS\TEMP, then reboot the server (set both the global and the per-user variables). Then do the install as a local Administrator.


Once that problem is resolved, you'll still be left with the SNMP credential problem. It looks like you have bad credentials configured in DCR for 10.250.1.94 and 172.16.2.20.


Once you take care of doing a proper installation and correcting the credentials, you shouldn't have any further problems.

Actions

This Discussion