831 DSL (Can only access some web sites)

Unanswered Question
Dec 26th, 2007


I just got and configured a Cisco 831 router. The IOS is 12.4. The router is connected to a DSL modem and goes to internet. The problem is, from PC in my LAN, only some web sites can be accessed, like google.com. Some web sites cannot be opened, like weather.com. I tried trace route, the routing goes to the 831 router (the only gateway). I telnet to 80 port of those web sites, and it works.

So I really got no idea what could be wrong. Can you please advise? I attached my running-config.

ANY suggestion will be greatly appreciated!!!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Brandon Buffin Wed, 12/26/2007 - 12:38

Add the following command to your configuration in global config mode:

ip classless

Hope this helps. If so, please rate the post.


panweicisco Wed, 12/26/2007 - 13:51

I added "ip classless", but the problem is still there.

Maybe I should clarify the problem a bit more. Say from PC1 in my LAN, do the following tests:

1. In IE, open google.com website, result: Webpage looks good.

2. In IE, open weather.com website, result: Webpage doesn't open.

3. In DOS prompt, do "telnet weather.com 80", get the black screen, means telnet session is established to weather.com's 80 port.

So I'm suspecting something above Layer 4. But it's just my guess, as I got absolutely no clue.

I appreciate your suggestion! :)

panweicisco Thu, 12/27/2007 - 07:56

The following commands fixed the problem.

Thanks to p.bevilacqua!


int dialer1

ip tcp adjust-mss 1452


This Discussion