802.1x on Cisco Catalyst 2960

Unanswered Question
Dec 26th, 2007
User Badges:
  • Silver, 250 points or more

I am trying to enable 802.1x on one of

the switchports of the Cisco Catalyst

2960:


C2960#sh run | i radius

aaa authentication login test group radius local

aaa authentication dot1x default group radius

radius-server host 10.250.97.26 auth-port 1812 acct-port 1813

radius-server source-ports 1645-1646

radius-server key 123456

C2960#sh run | i dot

aaa authentication dot1x default group radius

dot1x system-auth-control

dot1x guest-vlan supplicant

dot1x critical eapol

C2960#conf t

Enter configuration commands, one per line. End with CNTL/Z.

C2960(config)#int g0/14

C2960(config-if)#dot1x ?

% Unrecognized command

C2960(config-if)#dot1x


As you can see, I can not enable 802.1x

at the interface level. The code is am running is 12.2.25SEE4:


Switch Ports Model SW Version SW Image

------ ----- ----- ---------- ----------

* 1 24 WS-C2960G-24TC-L 12.2(25)SEE4 C2960-LANBASEK9-M


System image file is "flash:c2960-lanbasek9-mz.122-25.SEE4.bin"


According to Cisco, this image supports

802.1x. Why can't enable it at the

interface level?


Can someone help me out? Thanks.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
cisco24x7 Wed, 12/26/2007 - 20:53
User Badges:
  • Silver, 250 points or more

some additional info:


C2960#sh dot1x all

Sysauthcontrol Enabled

Dot1x Protocol Version 2

Critical Recovery Delay 100

Critical EAPOL Enabled


C2960#


Jon Marshall Tue, 01/01/2008 - 11:22
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Hi


Before typing dot1x under interface try


C2960(config)#int g0/14

C2960(config-if)# switchport mode access

C2960(config-if)# dot1x ?


Jon


MJonkers Thu, 04/24/2008 - 04:44
User Badges:

This works only if switchport is access port. So configure switchport mode access.

Jagdeep Gambhir Thu, 04/24/2008 - 05:17
User Badges:
  • Red, 2250 points or more

You must input "swithport mode access" first, then you can input 802.1x cmd.




Regards,

~JG


Do rate helpful posts

Actions

This Discussion