EIGRP Wildcard command

Unanswered Question
Dec 27th, 2007

Can some explain what is the purpose of the wildcard in EIGRP.

When should it be used?

When should it no be used?

Why would we use it on a loopback interface?

Please let me know..

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
royalblues Thu, 12/27/2007 - 00:26

EIGRP wildcard masks are used to control the interfaces on which you want the EIGRP to operate

For eg.. say if you have 3 interfaces having the following ip address 10.10.10.1/24 10.10.20.1/24 and 10.10.30.1/24

Now if you use the follwoing network command under EIGRP

router eigrp 100

network 10.0.0.0

it will start EIGRP on all the interfaces but if you wanted to run it on only 10.10.10.1 you would use

router eigrp 100

network 10.10.10.1 0.0.0.0

The case is similar for loopbacks as we generally use /32 subnet mask for them and hence need not want to run EIGRP on the entire subnet

HTH

Narayan

Mavrick25 Thu, 12/27/2007 - 00:59

Is it safe to say that with loopback interfaces there really isn't a need to include the wildcard then.

because it is a /32?

What do you think?

It really isn't a practice that I am used to performing..

Let me know..

royalblues Thu, 12/27/2007 - 02:25

It depends

say for example you have 3 loopbacks defines

Lo1-10.10.10.1/32, LO2-10.10.10.2/32, LO3-10.10.10.3/32

Now if you configure

router eigrp 10

network 10.10.10.0 ---> this will be converted to 10.0.0.0 and EIGRP will run on all interfaces

If you wanted to trestrict on one interface

you would do

router eigrp 10

network 10.10.10.0 0.0.0.0

Again, it totally depends upon the user requirements. Generally it is a best practice to not turn on EIGRP on the interfaces that need be running them

HTH

Narayan

a.hajhamad Thu, 12/27/2007 - 04:38

Hi Narayan,

Just to correct:

If you wanted to trestrict on one interface

you would do

router eigrp 10

network 10.10.10.0 0.0.0.0

I think you mean network 10.10.10.(1) "not 0" 0.0.0.0

and i think for the interface to use the subnet mask "wildcard" for the interface

For example:

interface serial 1/0/0

ip address 10.10.10.1 255.255.255.0

you have to add

router eigrp 10

network 10.10.10.1 0.0.0.255

Right?

Thanks

abd Alqader

royalblues Thu, 12/27/2007 - 04:42

Yes..

thanks for correcting the typo

it should have been 10.10.10.1 0.0.0.0

Narayan

Mavrick25 Thu, 12/27/2007 - 05:30

I have another question:

It makes perfect sence for subnet addresses because the subnets are attached to the interface.

turning our attention to loopback address..

if configuring a loopback interface lets say:

loopback 0

3.3.3.3 255.255.255.255

This is a virtual address, logical not assigned to an interface.

How can you control which interface propagates the address out..

a.hajhamad Thu, 12/27/2007 - 05:39

The router will propagates this address "loopback" to its EIGRP neighbors using the interfaces used for establishing the EIGRP neighbors.

If you want to control the Propagation process, use distriubute-list command inside the EIGRP config.

Regards

Abd Alqader

Actions

This Discussion