VLAN limitation issues with 2960/3550 or 3500XL series

Unanswered Question
Dec 27th, 2007

Hey all,

I've a big problem with several Cisco 2600 switches in our network.

Here's the senerio....

1, Very large campus

2, A LOT of vlans

3, More vlans planned for an ongoing project and even more for an upcomming

project.

4, The biggie...must use VTP, customer wants a centralized point to manage

their vlans.

Total amount of vlans will be in excess of 255.

I think to myself, should be no problem. I'll do vtp pruning at the core and

also only allow specific vlans on specific trunks.

Well, I lab'd it before implementing and it's not working the way I

anticipated....Pruning is working great, restricting what vlans can traverse

the trunk is also working great. Problem is that all the vlans are still

being advertised thru VTP. What's happening is that the 2950's and 3500's

are reverting back to transparent mode due to their vlan limitation.

Getting a message "%SW_VLAN-6-VTP_MODE_CHANGE: VLAN manager changing device

mode from CLIENT to TRANSPARENT."

Thus the access layer switches do not learn about any of the vlans,

everything breaks, and I get frustrated.

Am I missing something here folks? Ideas? Do there is a possibility to restrict the "local vlans"

And what does it mean on the whitepaper "support more than 4000 Vlan ID's"?

Thanks,

Franco

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
glen.grant Thu, 12/27/2007 - 05:08

What you need to do is on the connecting links to these devices you need to "manually" prune off the vlans allowed across these links to only those vlans actually needed on say the 2960. This will fix this problem . On the connecting links on both sides add "switchport trunk allowed vlans xx " . XX is the vlans you want allowed across the trunk link. These old and smaller switches cannot support that many spanning tree sessions for pvst+ . When you "manually" prune off those vlans not needed on the links this reduces the spanning tree requirements for that switch . A 2960 certainly does not need to support 255 vlans. If you need to add a vlan to say the 2960 in the future then all you have to do is allow that vlan across the trunk on both sides . Vtp pruning and manually pruning them off the links are not the same. The switch is working normally when it puts the switch in transparent mode because it cannot support that many spanning tree instances.

francofronzino Thu, 12/27/2007 - 07:14

Hi Glen

I tried now to follow your suggestion. But it still doesn't work. I configured 260 Vlan's.

What I did:

Testlab Switch1 (Server):

set trunk 2/48

clear trunk 2/48 5-260

VTP Prunning enabled

Testlab Switch2 (Cisco2960 Client):

int gigabitethernet 0/48

switchport trunk allowed vlan 2-4

switchport trunk prunning vlan 5-260

Is that right? To be honest I tried all the methods that are available.

Thanks in advance for your help.

Regards Franco

glen.grant Thu, 12/27/2007 - 07:47

Check to see what is allowed on the trunks on both sides . Use a show trunk or a show int trunk on a IOS box to check . We use 2950's in the same type scenario and it works fine and we had the same issue before we disallowed the not needed vlans across the trunk. We did not use

switchport trunk prunning " command .

francofronzino Thu, 12/27/2007 - 23:07

Hi Glen

Could you pls send me the config from both sites? I tried almost everything yesterday without success.

Thanks in advance.

Regards Franco

david.macia Fri, 12/28/2007 - 05:14

Hi,

I think that the problem is that you want to create a vlan with a number higher than 1200. Can you try to create this vlan with a lowest number?

Bye!

francofronzino Fri, 12/28/2007 - 05:38

No this is not the problem.

My problem is the following:

I have a VTP Server(Cisco6509 CatOS) with 255 Vlan's configured. As Access Switch I have a Cisco 2960(VTP Client) also in the same VTP Domain. As soon I configure a new VLAN on the VTP Server my VTP Client (Cisco 2960) changes the VTP mode to Transparent. The reason is that it exceeds the limitation of 255 VLAN's. Now my question is if there is solution to limit the local VLAN's on the Cisco 2960. On the cisco page it's written:

Up to 255 VLANs per switch and up to 128 spanning-tree instances per switch are supported.

Four thousand VLAN IDs are supported.

What do they mean with: "Four thousand VLAN IDs are supported?" As soon I configure VLAN 256 I got this problem.

I already tried to limit the VLAN's on the trunk both sides but also without success.

In my opinion it's not possible that there is no solution to limit the local VLAN's. I hope somebody of you can help me asap.

Regards Franco

david.macia Fri, 12/28/2007 - 06:04

Hi Franco,

put this command in your switch: show vtp status example:

show vtp status

VTP Version : 2

Configuration Revision : 0

Maximum VLANs supported locally : 254

Number of existing VLANs : 5

VTP Operating Mode : Server

Please, be careful with the max vlans supported locally. If you want to increase this number, put VTP mode transparent. But with this command you lost the centralized management.

Bye

francofronzino Fri, 12/28/2007 - 06:08

Hi David

I already did that:

VTP Version : 2

Configuration Revision : 414

Maximum VLANs supported locally : 255

Number of existing VLANs : 254

VTP Operating Mode : Client

VTP Domain Name : x

VTP Pruning Mode : Enabled

VTP V2 Mode : Disabled

VTP Traps Generation : Disabled

So there is no solution how to handle more then 255 Vlan's via VTP on the Cat2960?

francofronzino Fri, 12/28/2007 - 06:18

No this is not the problem.

My problem is the following:

I have a VTP Server(Cisco6509 CatOS) with 255 Vlan's configured. As Access Switch I have a Cisco 2960(VTP Client) also in the same VTP Domain. As soon I configure a new VLAN on the VTP Server my VTP Client (Cisco 2960) changes the VTP mode to Transparent. The reason is that it exceeds the limitation of 255 VLAN's. Now my question is if there is solution to limit the local VLAN's on the Cisco 2960. On the cisco page it's written:

Up to 255 VLANs per switch and up to 128 spanning-tree instances per switch are supported.

Four thousand VLAN IDs are supported.

What do they mean with: "Four thousand VLAN IDs are supported?" As soon I configure VLAN 256 I get this problem.

I already tried to limit the VLAN's on the trunk both sides but also without success.

In my opinion it's not possible that there is no solution to limit the local VLAN's. I hope somebody of you can help me asap.

Regards Franco

bmcghee Mon, 04/12/2010 - 07:55

Hi Franco,

     Where you able to resolve this issue?  I'm running into the same issue and am looking for a solution..

Thank you..

Giuseppe Larosa Mon, 04/12/2010 - 09:36

Hello BMcghee,

switchport trunk allowed vlan can help in keeping as low as possible the number of STP instances in each device but if there are more vlans then those supported in VTP the low end switch will revert to VTP transparent mode to protect itself.

And this is the only possible workaroung move access layer devices to VTP transparent mode, manually delete on each of them unused vlans to get space to add some vlans in the future.

Hope to help

Giuseppe

Vincenzo Santoro Thu, 12/01/2011 - 06:41

Hi Giuseppe,

I've exactly the same problem. Basically I've one 4506 configured as vtp server and several 2960s configured as vtp client. Both are ruinning VTP V3.

Since more than 255 VLANs have been configured on the 4506, all the 2960s have automatically changed from client to transparent mode.

I tried with "switchport trunk allowed" but it didn't work. In fact, even if I on one trunk between the 4506 and one 2960 only a couple of vlan are allowed, the vtp protocol trasmits to the 2960 the info about all the vlans defined on the 4506.

So, according to what you wrote in the previous post there is no possibility to use the 2960s switches in client mode in this scenario. Can you confirm that?

Regards,

Vincenzo

Jigar Dave Sat, 12/03/2011 - 12:04

All,

My take for this:

Try to upgrade IOS on 2960 switches

what is a problem if 2960 be in transparent mode instead of client mode?

glen.grant Sat, 12/03/2011 - 20:06

   thats what Guiseppe is saying , it is a hardware limitation of the low end switch. 

Actions

This Discussion