Cisco T1 compatability with Paradyne and non-Cisco

Unanswered Question
Dec 27th, 2007

Hello,

A customer recently purchased the PA-MC-8TE1+ module for their 7500 Router at their head office. They would like for the T1 module to connect to their remote offices that have Paradyne CSU/DSU's which connect to a 2801 Cisco Router via V.35 cable to a serial port. Before testing this via the actual T1 link, we decided to test the equipment first via a T1 crossover cable (back-to-back) just to make sure that everything is working correctly.

I configured both the Cisco T1 module and the Paradyne CSU & DSU to use B8ZS linecoding and ESF framing. And since this is a back to back connection, I configured the Cisco router to run the internal clocking. I then configured the IP Address's on both routers within the same subnet and used Encapsulation PPP, yet despite my best efforts, I only get Line Up and Protocol Down.

When checking the Paradyne equipment, they indicate that the connection is established without any problems.

The actual Part Numbers for the Paradyne CSU/DSU are 7974 TDM SDSL and 7975 TDM SDSL.

I know this is a stupid question, but does Cisco integrate with non-Cisco CSU/DSU's? I would appreciate any help and working configuration samples with similar non-cisco products.

Thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Paolo Bevilacqua Thu, 12/27/2007 - 10:55

Yes it does integrate, also because cisco does't make external csu/dsu.

Collect show interface and show controller on both routers, send it here together with configuration.

mo.ragheb Tue, 01/01/2008 - 07:53

Dear all,

Here is the Show interface and show run for the branch router

Serial0/0/0 is up, line protocol is down

Hardware is GT96K Serial

Description: connection to Basateen Computer room

Internet address is 10.0.30.34/30

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

reliability 250/255, txload 1/255, rxload 1/255

Encapsulation PPP, LCP Listen, loopback not set

Keepalive set (10 sec)

Last input never, output 00:00:24, output hang never

Last clearing of "show interface" counters 00:00:42

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

21 input errors, 21 CRC, 11 frame, 9 overrun, 0 ignored, 15 abort

10 packets output, 140 bytes, 0 underruns

0 output errors, 0 collisions, 4 interface resets

0 output buffer failures, 0 output buffers swapped out

0 carrier transitions

DCD=up DSR=up DTR=up RTS=up CTS=up

Show Run:

interface Serial0/0/0

description T1 connection to Head Office

ip address 10.0.30.34 255.255.255.252

encapsulation ppp

no ip mroute-cache

no fair-queue

!

router rip

version 2

redistribute connected

network 10.0.0.0

!

Here is the Show interface, show controller and show run for the main 7500 Router

Show Controller:

show controllers t1 5/0/3 brief

T1 5/0/3 is up.

Applique type is Channelized T1

Cablelength is short 110

No alarms detected.

alarm-trigger is not set

Framing is ESF, Line Code is B8ZS, Clock Source is Internal.

Data in current interval (722 seconds elapsed):

0 Line Code Violations, 0 Path Code Violations

0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

Total Data (last 24 hours)

0 Line Code Violations, 0 Path Code Violations,

0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

Show Interface:

show int serial 5/0/3:1

Serial5/0/3:1 is up, line protocol is down

Hardware is Multichannel T1/E1 without TDM

Internet address is 10.222.30.3/24

MTU 1500 bytes, BW 1536 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation PPP, LCP Listen, crc 16, loopback not set

Last input 1d04h, output 00:00:31, output hang never

Last clearing of "show interface" counters 4d01h

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/1/256 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

Available Bandwidth 1152 kilobits/sec

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

106 packets input, 680 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 1 giants, 0 throttles

1 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 115024810 abort

69820 packets output, 977480 bytes, 0 underruns

0 output errors, 0 collisions, 6988 interface resets

0 output buffer failures, 0 output buffers swapped out

9 carrier transitions no alarm present

Timeslot(s) Used:1-24, subrate: 64Kb/s, transmit delay is 0 flags

Transmit queue length 27

Show run:

controller T1 5/0/3

framing esf

clock source internal

linecode b8zs

cablelength short 110

channel-group 1 timeslots 1-24

interface Serial5/0/3:1

ip address 10.222.30.3 255.255.255.0

encapsulation ppp

keepalive 10 0

!

router rip

version 2

network 10.0.0.0

Richard Burts Tue, 01/01/2008 - 08:17

Mohamed

I notice that the LCP on both ends is in the Listening state and I wonder if they are hearing anything. Is it possible that the T1 crossover cable is not correct? Can you use it to connect other routers T1 interfaces and it works? Or can you use it to connect 2 T1 interfaces on the 7500 and it works?

I also note a serious mismatch in addressing:

the branch router has

ip address 10.0.30.34 255.255.255.252

while the 7500 has

ip address 10.222.30.3 255.255.255.0

It makes me wonder whether we are looking at the right interfaces, or whether you are disguising things - and if so are you disguising more than the addresses which might help hide the real problem.

To go back to your original post and the question that it asks:

does Cisco integrate with non-Cisco CSU/DSU's

it is certainly true that Cisco integrates with non-Cisco CSU/DSU equipment.

HTH

Rick

mo.ragheb Tue, 01/01/2008 - 10:15

Hello Rick,

Good catch, i just realized that i posted the old configuration with the wrong ip address... without making this post more complicated, rest assured that both routers are on the same subnet, the branch router ip address is in fact 10.222.30.1/24, and the show controller and show interface commands were taken while these ip addresses were in the same subnet. With regards to the T1 crossover cable, it's been used before and works fine. any ideas as to what else could cause this?

Thanks

vinay_verma80 Tue, 01/01/2008 - 20:51

hi

I suppose u have not included "Framing is ESF, Line Code is B8ZS, Clock Source is Internal. " in branch router for the controller

plz include it

regards

mo.ragheb Wed, 01/02/2008 - 01:55

The branch router is connected to a Paradyne CSU/DSU, those are configured for framing ESF and line code b8zs as mentioned in the very first post.

vinay_verma80 Sun, 12/30/2007 - 12:29

Hi

Try to use clocking internall on the Paradyne also ( along with the cisco also as internal)

see what is the result

if the problem has been solved or not( I know this is weried , but it happens but it can give u error but ur line protocol will be up )

If u don't get ur line protocol up check the pin connection ( v.35 cross cable b/w both of the routers

If both these solution don't solved ur problem plz past ur run conf and the sh controller status

regards

Anonymous (not verified) Mon, 12/31/2007 - 04:37

It probably is a configuration issue somewhere, unless you have some bad hardware, you can check that with an E1 loop back adapter on both ends with the encapsulation set to HDLC. Protocol should come up, and if all is good you will be able to pint the serials IP address. If that is the case check all the settings on both ends, pay attention to timeslots, framing settings, ect.

Actions

This Discussion