CDP not publishing network

Answered Question
Dec 27th, 2007

I'm new to ODR/CDP and having a problem getting a network dynamically published from my spoke router. My setup is this:

The hub is a 3640, and the spoke is a 2600, both with IOS 12.3. The 3640 is running both ODR and RIP. The 2600 has no routing protocols enabled, but ip routing is enabled. S0/1 of the 3640 is connected to S0/0 of the 2600. 3640-S0/1 is 192.168.4.1/24 and 2600-S0/0 is 192.168.4.2/24. On the 2600 Ethernet0/0 is assigned 192.168.5.1/24.

On the 2600, in show ip route, I see an 'o' entry for the default route to 192.168.4.1 (correct) and 'C' for 192.168.5.0 and 192.168.4.0. On the 3640, show ip route has an 'o' entry for 192.168.5.0 and 'C' for 192.168.4.0. So far, all as I expect. Pings between all interfaces on the 3640 and 2600 are successful.

The problem is no other router connected to my hub (all other routers are using RIP) have any entry for 192.168.5.0. For another router connected to the 3640, I would expect to see an 'R' entry for 192.168.5.0 pointing back to the 3640. The route is invisible outside of the hub and spoke.

All of routes and interfaces are working fine through RIP on all routers. On the 3640, under router rip, I've tried having network 192.168.4.0 and not having it, same results both ways. I've also tried adding in 'redistribute odr' into 'router rip', again, with no affect.

I'm missing something. Any ideas?

I have this problem too.
0 votes
Correct Answer by Edison Ortiz about 8 years 11 months ago

Paolo is right on target (as always :)). When redistributing from a dynamic routing protocol into RIP, you need to specify a metric - if you don't, it's automatically set to 16 (unreachable).

http://www.cisco.com/univercd/cc/td/doc/product/software/ios124/124cg/hirp_c/ch20/piconfig.htm#wp1001239

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.

Actions

This Discussion