cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1163
Views
0
Helpful
7
Replies

How to configure two 1720's over T1 PTP using IP routing

jeggleston
Level 1
Level 1

I currently have a PTP T1 that has two 1720 's configured to use bridging. I would like to use ip routing instead of bridging. My 1720's have wic-t1 cards and use Kentrix, DataSmart 658's as DSU/CSU. When I enable ip routing on local 1720 I loose my connection to the local router and the remote facility. My running-configs are below.

Br_1720#sh ru

Current configuration:

!

version 12.1

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Br_1720

!

enable password 7 xxxxxxxxxxx

!

!

!

!

memory-size iomem 25

ip subnet-zero

no ip routing

no ip domain-lookup

!

!

!

!

interface Serial0

ip address 10.210.4.3 255.255.255.0

no ip route-cache

no fair-queue

bridge-group 1

!

interface FastEthernet0

description connected to EthernetLAN_1

ip address 10.210.4.13 255.255.255.0

no ip route-cache

speed 100

full-duplex

bridge-group 1

!

ip classless

no ip http server

!

access-list 50 permit 10.210.2.xx

access-list 50 permit 10.210.2.xx

access-list 50 permit 10.210.2.xx

access-list 50 permit 10.200.10.xx

access-list 50 permit 10.200.10.xx

access-list 50 permit 10.210.4.xx

access-list 50 permit 10.210.2.xx

access-list 50 permit 10.50.200.xx

access-list 50 permit 10.200.10.xx

snmp-server engineID local

snmp-server location Bro

snmp-server contact JE

bridge 1 protocol ieee

!

line con 0

exec-timeout 0 0

password 7 xxxxxxxxx

login

transport input none

line aux 0

line vty 0 4

access-class 50 in

password 7 xxxxxxxxxxxxxx

login

!

end

--------------------------------

Mi_1720#sh ru

Current configuration:

!

version 12.1

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Mi_1720

!

enable password 7 xxxxxxxxx

!

!

!

!

!

memory-size iomem 25

ip subnet-zero

no ip routing

no ip domain-lookup

!

!

!

!

interface Serial0

ip address 10.210.4.2 255.255.255.0

no ip route-cache

no fair-queue

bridge-group 1

!

interface FastEthernet0

description connected to EthernetLAN_1

ip address 10.210.4.12 255.255.255.0

no ip route-cache

speed 100

full-duplex

bridge-group 1

!

ip classless

no ip http server

!

access-list 50 permit 10.210.2.xx

access-list 50 permit 10.210.2.xx

access-list 50 permit 10.210.2.xx

access-list 50 permit 10.200.10.xx

access-list 50 permit 10.200.10.xx

access-list 50 permit 10.210.4.xx

access-list 50 permit 10.210.2.xx

access-list 50 permit 10.50.200.xx

access-list 50 permit 10.200.10.xx

snmp-server engineID local

snmp-server community public RO

snmp-server location Server Room

snmp-server contact je

bridge 1 protocol ieee

!

line con 0

exec-timeout 0 0

password 7 xxxxxxxxxxxx

login

transport input none

line aux 0

line vty 0 4

access-class 50 in

password 7 xxxxxxxxxxx

login

!

no scheduler allocate

end

-------------------------------

I would like to enable RIP Version 2.

Would appreciate any help.

Thanks much.

jeggleston@wplg.com

7 Replies 7

Edison Ortiz
Hall of Fame
Hall of Fame

1) You need to create a subnet for the WAN PTP Link

For instance on Router A:

interface Serial0

ip address 10.210.1.1 255.255.255.252

no ip route-cache

no fair-queue

On Router B:

interface Serial0

ip address 10.210.1.2 255.255.255.252

no ip route-cache

no fair-queue

2) You need to pick which site is going to keep the subnet 10.210.4.0/24.

You can't have both sites with the same IP subnet while performing routing between them.

For instance on Site A:

interface FastEthernet0

description connected to EthernetLAN_1

ip address 10.210.4.1 255.255.255.0

speed 100

full-duplex

While on Site B:

interface FastEthernet0

description connected to EthernetLAN_1

ip address 10.210.3.1 255.255.255.0

speed 100

full-duplex

Then you can configure RIP version 2

router rip

version 2

network 10.0.0.0

no auto-summary

Thank you for the excellent response.

I have two questions, will modifying the ip addresses break my current network connection to both routers? Also, would Proxy Arp allow me to keep my current addressing scheme?

My apologies if these questions are inappropriate.

Thanks again,

JE

Yes, you need to make these changes while connected to both routers via the console port.

If you can't be onsite, you can connect a modem to the aux or console port and manage the router this way.

No, Proxy ARP won't help you keeping the same addressing scheme. The router won't receive a route that it already has.

Thank you again. We have a "No Change Friday" policy so I won't be able to implament you instructions until next week. Have a Happy New Year!

Good luck and make sure to post back with results.

Jeff

I agree with Edison that the optimum solution is to have someone on the console port of each router making the config changes. If it is difficult to do this I have an alternative that you may consider.

- first plan out the changes that you will need to make (I agree with Edison that at a minimum you need a unique subnet for both Ethernets and for the serial link. You also need to make sure that you have the routing logic straightened out - whether it is RIP 2 or something else.

- create text files for each router with the appropriate config changes for that router.

- login to the remote router (you want to change the remote router first so that when you lose that connection you can make changes on the local router that will hopefully restore connectivity.

- schedule a reload (reload in 30 - or whatever time interval you think appropriate) so that if the config changes do not work as expected the router will reboot and will go back to the original/working config.

- tftp the text file with changes for the remote router to running config. This should apply the changes to the remote router and should lose connectivity at this point.

- login to the local router.

- cut and paste (or tftp) the changes to running config. If the config changes on both ends were well planned and correctly executed this should restore connectivity. If the changes do not work, reboot the local router and wait for the scheduled reload of the remote router.

- if the changes do work and connectivity is restored then login to the remote router, cancel the reload, and save the running config to startup config.

HTH

Rick

HTH

Rick

ohassairi
Level 5
Level 5

to be sure your new addressing schema is good check this

http://hassairi.50megs.com/#osama

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card