2600 Encapsulation ERROR!!!! Help Me PLease!!!

Unanswered Question
Dec 27th, 2007
User Badges:

Whenever I try to configure my sub interface on my ethernet port with a IP ADDRESS I get the message below. I have tried several routers and all of them give me the same ERROR. 2620, 2610 and 2620


Configuring IP routing on a LAN subinterface is only allowed if that

subinterface is already configured as part of an IEEE 802.10, IEEE 802.1Q,

or ISL vLAN.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (2 ratings)
Loading.
steve.busby Thu, 12/27/2007 - 20:28
User Badges:
  • Silver, 250 points or more

Before you add the IP address configure the subinterface as a dot1q trunk.


interface type slot/port.subinterface-number

encapsulation dot1q vlan-id

ip address


HTH

Steve

david.macia Fri, 12/28/2007 - 05:01
User Badges:

Hi,


inside the configuration in the interface, put this command:


encapsulation dot1q vlan XXX


XXX = vlan number


After this, you can put the ip address in the interface.


Merry Christmas!

Charlie Mayes Fri, 12/28/2007 - 05:24
User Badges:

The encapsulation command is not available I checked for it by using the ? symbol.

david.macia Fri, 12/28/2007 - 05:37
User Badges:

I'm sorry, not in interface. Put encapsulation command in subinterface...

Charlie Mayes Fri, 12/28/2007 - 07:23
User Badges:

I knew what you meant earlier. I did try it in the sub-interface. I used the ? symbol and the encap command was not available. Thanks for your help.

ankbhasi Fri, 12/28/2007 - 07:38
User Badges:
  • Cisco Employee,

Hi Friend,


Check you image as you need to have minimum IP PLUS feature set image loaded on your router to suppotr encaosulation command.


HTH


Ankur


*Pls rate all helpfull post

Charlie Mayes Fri, 12/28/2007 - 07:41
User Badges:

How do I find how what image has the IP PLUS? Is there a link on Cisco's site that will tell me what IOS will include it for my 2620? You have been really helpful.

Richard Burts Sat, 12/29/2007 - 19:55
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Charlie


If you post the output of show version, there is information included in the file name that will normally tell which feature set of code you are running.


You may use the Feature Navigator on the Cisco site to investigate what versions and feature sets of code for 2620 support the encapsulation command:

www.cisco.com/go/fn


HTH


Rick

Charlie Mayes Sun, 12/30/2007 - 06:03
User Badges:

Thanks rburts and everyone else for your help. I think the IOS I does not have the encapsulation features I need to setup router on a stick. I also found that I need more memory to load the IOS that does. Thanks again for all your help. This site is great.

Actions

This Discussion