Ciscowork RME not able to fetch config from CatOS device

Unanswered Question
Dec 28th, 2007
User Badges:

getting below error

CM0056 Config fetch failed for ATL-6506-1-2 Cause: CM0204 Could not create DeviceContext for 249 Cause: CM0206

Please help

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
David Stanford Fri, 12/28/2007 - 06:52
User Badges:
  • Cisco Employee,

What version of RME is this and what device type (sysObjectID)?


This error has been seen a few times when the service pack does not support the hardware you are trying to fetch the config for.

amit.kango Fri, 12/28/2007 - 06:59
User Badges:

thanks Davistan, what can get is

we are using LMS2.6 and i am using 6506 swtich with 8.4 2a,

pls help if how to get sysobjectid if you require

David Stanford Fri, 12/28/2007 - 07:21
User Badges:
  • Cisco Employee,

You'll need to do an snmpget/walk on the switch to get the sysObjectID. Is this a 6506 or something like 6506-E?


Also, still need your version of RME

amit.kango Fri, 12/28/2007 - 07:42
User Badges:

1.3.6.1.2.1.1.2. --sysObjectID


Hardware Version: 3.0 Model: WS-C6506


Version & Patch Level:

4.0.6 -RME version.


Please let me know if your require more info thanks again


David Stanford Fri, 12/28/2007 - 07:50
User Badges:
  • Cisco Employee,

This isn't the sysObjectID of the device, this is just the numerical OID for the object itself.


You'll want to go to Device Troubleshooting - Device Center and then select the device and when the main frame loads select snmpwalk. Then enter either 1.3.6.1.2.1.1.2 or sysObjectID as the object you want to walk. What is the result?

amit.kango Fri, 12/28/2007 - 07:58
User Badges:

sorry, here is result


RFC1213-MIB::sysObjectID.0 = OID: CISCO-STACK-MIB::wsc6506sysID

David Stanford Fri, 12/28/2007 - 08:14
User Badges:
  • Cisco Employee,

This is a 6506-E which is supported in your version


Is there a FWSM in this switch?


You might want to enable debugs for ArchiveMgmt in under RME - Admin - System Preferences - Loglevel Settings and then try a sync archive on the switch.


Also, enable a packet capture at the same time

amit.kango Fri, 12/28/2007 - 08:23
User Badges:

i will do that but does it slow the device ?

if yes then i might need to run in night i.e. 12hrs from now

and what this result will give info?

David Stanford Fri, 12/28/2007 - 08:30
User Badges:
  • Cisco Employee,

These aren't device level debugs, they are application debugs.

amit.kango Fri, 12/28/2007 - 08:38
User Badges:

thanks a lot. i have started the archive mgmt job now. job completed wher cani get output which you required

David Stanford Fri, 12/28/2007 - 08:59
User Badges:
  • Cisco Employee,

Don't forget about the packet capture which you'll want to look at as well.


the debug output will be in te dcmaservice.log

amit.kango Sat, 12/29/2007 - 19:43
User Badges:

Hi Davistan,


i am extremely sorry for troublehsoot this again as i went on leave, but i would lik this to be continue from tomorrow morning

if possible thank you.

amit.kango Sun, 12/30/2007 - 20:47
User Badges:

Hi Davistan an all, i am attaching the log file for you, please help me in closing this issue. thanks a ton



Attachment: 
amit.kango Tue, 01/01/2008 - 20:24
User Badges:

Hey guys,

can anyone please help in getting this cleared. thanks a ton

Joe Clarke Tue, 01/01/2008 - 20:46
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

You have not included the entire logs for which Dave asked. There is nothing we can get from these fragments.

amit.kango Tue, 01/01/2008 - 21:02
User Badges:

Hi Jclarke,


i am attaching the log again for your reference, please let me know if this is ok. couldnot do packet capture since software is not software installation.



Attachment: 
Joe Clarke Tue, 01/01/2008 - 21:13
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Please provide the list of contents in NMSROOT/MDC/tomcat/webapps/rme/WEB-INF/lib/pkgs and NMSROOT/classpath/com/cisco/nm/xms/psu/pkgs/rme.

Joe Clarke Tue, 01/01/2008 - 21:56
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Your lib/pkgs directory is missing the Cat6000.zip package. This package is critical for config archive to work on this 6506. You can copy this file from the pkgs/rme directory, then restart dmgtd, and the config archive problem should be fixed.

amit.kango Tue, 01/01/2008 - 22:00
User Badges:

Oh WOW, thats great news for me, i should be doing right away and will share the result with you. thanks a bunch dude.


amit.kango Tue, 01/01/2008 - 22:38
User Badges:

Jclarke, Amazing, my issue is resolved now. thanks a million you amde my day buddy.

amit.kango Wed, 01/02/2008 - 00:05
User Badges:

One last query on this Dude, wher can i get or download WAAS package to addit in Pkgs folder. thanks again.

Joe Clarke Wed, 01/02/2008 - 09:16
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

There is no WAAS package. The WAE 512 models are supported now in LMS 3.0.1 in the content engine packages. The other models like the 612 and NME will not be supported until next year. There is no support in LMS 2.6.

Actions

This Discussion