IP-EIGRP(Default-IP-Routing-Table

Unanswered Question
Dec 28th, 2007
User Badges:

Below is the error i am geting i have checked on both the ends the subnet is ok its /30. At one end the ip address over Fast ehernet is 172.19.242.218 /30 and at the other end G0/1 172.19.242.217/30 even the network advertised in Eigrp is 172.19.242.216 0.0.0.3,what could be the problem please assist.I have verified the speed and duplex its auto at FE end and nothing is specified at Gigabit port.




*Dec 28 22:32:10 GMT: IP-EIGRP(Default-IP-Routing-Table:100): Neighbor 172.19.24

2.218 not on common subnet for FastEthernet1/0

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
royalblues Fri, 12/28/2007 - 22:21
User Badges:
  • Green, 3000 points or more

Are the 2 routers connected directly or via a switch? Please share your topology


For Eg. this can happen if you have a setup something like this (all 3 routers connected to a switch)


R1

|

|

SW----R2

|

|

R3


Now lets say R1 = 172.19.242.217/30 and R2

= 172.19.242.218 /30 and R3 = 172.19.242.221 /30


though all the routers are in different subnet but are connected to the same switch (one vlan). so the EIGRP multicast packet 224.0.0.10 sent by R1 is seen at both R2 as well as R3.


R1 and R2 being on common subnet establish an adjacency but R3 not being on common subnet displays the above error.


If R3 is placed into another vlan, the above error should stop


HTH

Narayan

csco10716389 Fri, 12/28/2007 - 22:38
User Badges:

7206 is connected to L3 Switch directly and some other port of router 7206 are connected to the same layer 3 switch.i am getting error for each subnets connected over different ports of 7206. And the same error i am getting over 6509 switch.

royalblues Fri, 12/28/2007 - 22:46
User Badges:
  • Green, 3000 points or more

Then mostly the ports connecting to the 6509 switch would be in a common vlan (need not be common subnet) and hence in a common Broadcast domain


HTH

Narayan


please rate all useful posts

csco10716389 Fri, 12/28/2007 - 22:56
User Badges:

The topology is as below


7206------->6509 like the same three ports are connected to the switch.


6509 Switch port config.


interface GigabitEthernet0/1.16

encapsulation dot1Q 16

ip address 172.19.242.217 255.255.255.252

ip access-group MPLSFILTERINBOUNDTRAFFIC in

no ip redirects

no ip unreachables

no ip proxy-arp

arp timeout 900

no cdp enable


and the 7206 end id having the 218 IP,

please tell what is the issue and how to reolve this.

royalblues Fri, 12/28/2007 - 22:59
User Badges:
  • Green, 3000 points or more

can you please post the configs of all the 3 ports


Narayan

csco10716389 Fri, 12/28/2007 - 23:06
User Badges:

7206 port config


interface FastEthernet1/0

description *** To CPX11-6509 ***

ip address 172.19.242.218 255.255.255.252

duplex auto

speed auto

no cdp enable

!

interface FastEthernet1/1

ip address 172.19.242.222 255.255.255.252

duplex auto

speed auto

no cdp enable

royalblues Fri, 12/28/2007 - 23:10
User Badges:
  • Green, 3000 points or more

Sorry i was not specific, i would like the switch side port configurations


Narayan

csco10716389 Fri, 12/28/2007 - 23:44
User Badges:

Narayan,


The other end config is same as i send earlier for G0/1.16 omly the ip is different,

Please help why this error comes and what could ne the solution

royalblues Sat, 12/29/2007 - 05:05
User Badges:
  • Green, 3000 points or more

I am finding it difficult to understand the connectivity. If they are directly connected, why are you using subinterfaces?


THe config would make sense if the topology was 72xx --- SW--dot1q---65xx. You also say that the configs are similar on all the 3 ports which raises another doubt. The vlan associated with each subinterface should mostly be different


It would be better if you post your topology and the complete configs


Narayan

Richard Burts Sat, 12/29/2007 - 11:12
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Abhay


I wonder if it is possible that you have a cable cross connected so that the 7206 is not connected to what you think it is connected to. Can you trace the cables and verify the connections?


It is unfortunate that you have CDP disabled as this is a very good way to check for this kind of problem. Would it be possible to enable CDP on these interfaces and then to post the output of show cdp neighbor detail?


Could you also post the error message again being very specific about the interface on which the message is generated and posting that interface config again so that we can be very clear about this?


HTH


Rick

Actions

This Discussion