CSS11503 Multiple servers not active....

Unanswered Question
Dec 28th, 2007

This is my Load Balancer CSS11503 configuration

!*************************** GLOBAL ***************************

no restrict web-mgmt

cdp run

ip route 1

ip route 1

!************************* INTERFACE *************************

interface 1/1

bridge vlan 10

!************************** CIRCUIT **************************

circuit VLAN10

ip address

!************************** SERVICE **************************

service Server1

ip address

port 80 range 88

service Server2

ip address

keepalive type none

port 80 range 88


service Server3

ip address

port 80 range 88

!*************************** OWNER ***************************

owner Test

content Test

add service Server2

add service Server1

balance srcip

sticky-serverdown-failover redirect

vip address

add service Server3


MY load Balancer works fine only when one server is active that is server 2 but when i activate the server 1 and 3 i am not able to reach any of the server the iOS version is sg0810106 ( please let me know if you need more detail, waiting for your responce.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Gilles Dufour Sat, 12/29/2007 - 06:28

first, start by removing the command 'port 80 range 88' from all services.

The behavior of this command is most probably not what you think.

Then, since you are in one-armed mode, you need to guarantee that the server response goes back to the CSS.

One easy way is to add the following commands to your config

group clientnat

vip address

add destination service Server1

add destination service Server2

add destination service Server3


Let me know if this works.

Also be aware that you have not configured stickyness but source ip hashing loadbalancing.

This is different.

You may want to use 'balance roundrobin' with 'advanced-balance sticky-srcip'.




This Discussion