GRE/IPSEC and Windows name resolution??

Unanswered Question
Jan 1st, 2008

I have an GRE/IPSEC VPN tunnel backing up a T1 link. Telco problem brought the T1 down. Tunnel works/passes data but Window's name resolution was only working from "some" servers and pcs on either side of the tunnel. First, I was under the impression that GRE/IPSEC allowed this type of name resolution through the tunnel without needing WINS or lmhosts?? Second, Is there some way to configure the VPN Tunnel backup to pass everything that the Serial link does when it's up??

See config excerpts below:

Remote Site c1841-advsecurityk9-mz.124-3h

interface Tunnel0

description VPN Backup

ip address 172.19.0.2 255.255.255.252

ip mtu 1400

ip ospf message-digest-key 1 md5 Guide

ip ospf network point-to-point

ip ospf cost 10000

delay 1000

keepalive 10 10

tunnel source Loopback0

tunnel destination 1.1.1.1

Tunnel passes through PIX 515 at host site and terminates Host Site router. c1841-ipbase-mz.124-1c

interface Tunnel0

description VPN Backup

ip address 172.19.0.1 255.255.255.252

ip mtu 1400

ip ospf message-digest-key 1 md5 Guide

ip ospf network point-to-point

ip ospf cost 10000

delay 1000

keepalive 10 10

tunnel source Loopback0

tunnel destination 2.2.2.2

Thanks in advance,

Tony

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
htarra Mon, 01/07/2008 - 07:39

Once the tunnel has been established it will pass all the data. There is no problem in tunneling. And also I don't think this can be an MTU issue. Maybe we need to force the NETBIOS broadcasts from one network to another... try this: and also you have not given host name properly in your network

networkA -- etherneta -- router --tunnel --------VPN-------tunnel -- router--ethernetb -- networkB

At the config mode at those routers type:

ip forward-protocol udp 139

At etherneta configuration type:

ip helper-address

ip directed-broadcast

At ethernetb configuration type:

ip helper-address

ip directed-broadcast

At the tunnel interfaces at both routers type:

ip directed-broadcast

That should force the windows networking browsing broadcasts to travel from one network to another,

tcekada Mon, 01/07/2008 - 08:48

OK. Thanks for the reply. Makes sense. We will give it try.

Actions

This Discussion