Two services from one server in one content on CSS 11503

Unanswered Question
Jan 1st, 2008

Hello. I have 4 servers with 2 services on each, running on different port. These services is cluster application and runs under content, where created 8 services. But, CSS always send users only at first service at server. I cannot figure where is problem. When I check for keepalive, they all alive. I tryed stop second services at all servers, they stopped and 'show keepalive' show me right information.

P.S. I have Java application running under Tomcat. Maybe, you have recomendation about cookies, balance method etc...

service serv-01-8085

port 8085

ip address 10.77.12.11

keepalive type http

keepalive method get

keepalive uri "/ping"

keepalive port 8085

keepalive hash "c81e728d9d4c2f636f067f89cc14862c"

max connections 300

active

service serv-01-8086

port 8086

ip address 10.77.12.11

keepalive type http

keepalive method get

keepalive uri "/ping"

keepalive port 8086

keepalive hash "c81e728d9d4c2f636f067f89cc14862c"

max connections 300

active

........

content server-http

advanced-balance arrowpoint-cookie

vip address 10.77.12.01

add service serv-01-8085

add service serv-01-8086

add service serv-02-8085

add service serv-02-8086

add service serv-03-8085

add service serv-03-8086

add service serv-04-8085

add service serv-04-8086

protocol tcp

port 80

url "/*"

balance aca

active

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Gilles Dufour Wed, 01/02/2008 - 05:01

don't use 'balance aca'.

If you do not have enough traffic, you could end-up with all traffic going to one server.

Use roundrobin - the default. It fist most everybody's need.

Then, currently all your users probably have cookie pointing to server1 anyway. So you should create a different cookie name or clear the cookie table of all users.

The command to create a new name is 'arrowpoint-cookie name '.

After that, everything should work.

Gilles.

APolegayko Wed, 01/02/2008 - 07:38

Sorry, my post is unclear a little. It goes not at one server, only at one service. I have services serv-01-8085, serv-01-8086, serv-02-8085,... and serv-04-8086. And traffic goes only at services serv-*-8085 and never at serv-*-8086.

I will try disable aca and add name for cookie. Thanks! (if it doesn't help, i'll write here).

Gilles Dufour Wed, 01/02/2008 - 10:09

are you sure all the services are alive ?

check with 'show service summary'.

Or did you add the 2nd services after the first one ?

Gilles.

APolegayko Wed, 01/02/2008 - 19:50

Yes, all of them is alive. When i turn off second services (at port 8086), 'show keepalive' command show alive only 8085 services. All services added in one time.

APolegayko Fri, 01/11/2008 - 12:24

Today i execute commands:

1. suspend content

2. 'no balance' (to disable balance aca and switch to default)

3. 'arrowpoint-cookie name ccprod' (to define cookie name for content)

4. make content active

It doesn't help. All users come only at first instances on each server. And second stay idle.

r.gogunskiy Thu, 11/20/2008 - 03:45

Hello, I hava same problem.

I have 2 instances webservers on one hardware appliance.

All users come only at first instances with arrowpoint-cookie.

Have you found a solution to the problem?

Sorry for my bad english

Actions

This Discussion