871W configuring Internet access

Unanswered Question
Jan 1st, 2008
User Badges:

I am trying to replace a Dlink 614+ router with a 871W. The Dlink had 3 hardwired computers and one wireless connection connected to the Internet using Earthlink PPOE and DSL.


The Dlink is configured with required PPOE Earthlink user name and password.


I find the SDM disk provided does not list the 871 but I decided to use the CD anyway. The next problem I find is the Dlink doesn't have a CHAP or PAP setting like the 871 when configuring the PPOE.


Unlike the Dlink, I can't figure where the 871 stores it's WAN IP address. The 871 DHCP does assign LAN IP addresses but there is no connection to the Internet.


Since I could not figure the 871 PPOE settings, I disabled the PPOE and enable the Dynamic IP setting instead. That did not help.


Then I addressed the Earthlink modem and set that up to make the PPOE connection. However I still had no Internet.


Next I tried to select static IP address and enter the gateway address of the external modem. Still didn't get Internet.


I bought back the Dlink, disabled the modem PPOE and plugged the the WAN port of the 871 into the Dlink lan and not even computers connected to to Dlink could get on the Internet.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Loading.
farkascsgy Wed, 01/02/2008 - 05:04
User Badges:
  • Silver, 250 points or more

Hello Sir,


I have a 871w with an ADSL line and it works well. Please see the attached config and try to customize to your scenario.


Bye

FCS


Please rate me if I helped.



Attachment: 
techcoorc Thu, 01/03/2008 - 20:08
User Badges:


Thanks for posting your 871W configuration file. It is not an instant answer for me. Even if I was to load your configuration file and the router work, I would not know how to configure the 871W.


I will have to go line by line and try to guess why you choose the setting you did. I also have to try to guess if you deleted all the extra parameters I see in my configuration file like service tcp-keepalives-in.


techcoorc Sun, 01/06/2008 - 08:20
User Badges:

I wasn't expecting you to explain all lines. My point being that you didn't specifically address my issue but sent a configuration file that would answer a more broad issue of how to configure 871W. As a beginner I am overwhelm with information you sent.


I would had liked to get the version number. I feel safer if I am comparing configuration files with the same version.


Yes, for now I have to wander around on the Internet


dihog Mon, 01/07/2008 - 07:24
User Badges:

Try using a 12.4T version (if you don't have it already).

I had to upgrade to a T-version to get the routers ADSL going.


/D

techcoora Thu, 01/10/2008 - 20:29
User Badges:

Thanks for the information. No, I am at 12.3. I did find that the updates on the Cisco site require a contract so I had to take time to run that down. The rep says the contract been tied to this user name so I am coming in at a different user name.

farkascsgy Fri, 01/11/2008 - 01:12
User Badges:
  • Silver, 250 points or more

If you are satisfied with your current IOS, you don't need upgrade it - if all required services works fine just place in production.


bye

FCS


Please rate me if I helped.

techcoora Fri, 01/11/2008 - 10:44
User Badges:

The other person that posted stated

"I had to upgrade to a T-version to get the routers ADSL going.". I noted you are using 12.4. I not satisfied because the ADSL doesn't work. Therefore it makes sense to upgrade to 12.4.


My current roadblock is that I haven't been able to get to the 12.4 version to download it.

techcoora Sun, 01/27/2008 - 20:25
User Badges:

I am going to list my adventures for anyone following this thread.


The first thing I did was upgrade from 12.3 to 12.4 and select c870-advsecurityk9-mz.124-9.T7.bin. Turns out I didn't have enough RAM for a different version.


The above decision ran me into my first problem with farkascsgy configuration. The problem is that there are two different versions of IOS ADVANCED SECURITY and ADVANCED IP SERVICES. The version farkascsgy is for ADVANCED IP SERVICES. Another reference on Techrepublic http://articles.techrepublic.com.com/5100-1035_11-6102399.html uses the same ADVANCED IP SERVICES. In both cases there are more than one vlan.


Problem was I had the IOS ADVANCED SECURITY and that version has only a default vlan1.


In order to try to solve my Internet connection problem, I loaded the router so that I could use SDM. I noted that SDM placed the line ip address dhcp client-id FastEthernet4 under interface Dialer0. Later Cisco support would concur with farkascsgy that the line should read ip address negotiated. The Cisco support engineer did have me take out the lines

Dialer idle-timeout 0, Dialer persistent and dialer-group 1 found in farkascsgy as well as elsewhere on the Internet. That didn't fix the problem. I was asked to put in debug ppp nego and that showed the Pap authentication was failing. I reenter the ppp pap sent-username “username” password “password” and that allowed the authentication. Turns out Chap lines are not needed.


I could ping to an IP address but the DNS was not working. I tried to use the information in Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide to configure VPDN. However a Cisco Support said “I must tell you that

VPDN configuration is the old way to set up a pppoe connection, right now

you do not need it.”

The DNS settings was the next big difference between farkascsgy configuration and what I had to come up with. Apparently farkascsgy version relies on Domain line which I don't have.

I did have the Earthlink DNS servers listed before I talked to Cisco support:

ip name-server 207.69.188.185

ip name-server 207.69.188.186

Cisco support had me add ip dns server. From other Internet source, it appears that this just provides a local DNS server.


The next change was to add the DNS servers to DHCP pool. The Cisco support explaination was “Just to re-state, the dns-server statement inside the DHCP pool gives the DNS IP to the clients; and the ip name-server command in global configuration on the router is used by the router itself to look for the names on the Internet and hand them down to the clients. The router works as a relay agent for the DNS queries”


The final Wireless setup does match farkascsgy version.


farkascsgy Mon, 01/07/2008 - 22:51
User Badges:
  • Silver, 250 points or more

Sir,


I use C870-ADVIPSERVICESK9-M, 12.4(9)T3 IOS on my device.


bye

FCS


Please rate me if I helped.

Actions

This Discussion