Cannot load IOS via xmodem

Answered Question
Jan 1st, 2008

Hi All, i deleted the old IOS from 3750 switch, uploaded a tar version of the new one, unfortenatelly forgot to unzip and reloaded the switch. I am in Rommon mode and cannot upload the new bin IOS via xmodem probably because there is not enough space (only 3MB left, the tar image takes 12.5MB).

dir is not showing the tar file for some reason. This is what i get:

List of filesystems currently registered:

flash[0]: (read-write)

xmodem[1]: (read-only)

null[2]: (read-write)

bs[3]: (read-only)

Thus i cannot delete the tar...

However i know it is there becuase on boot the switch is showing theat 12MB are being used....

Any sugestions???

Correct Answer by MATTHIAS SCHAERER about 9 years 1 month ago

If you have not found it yet, this description should help you:

http://www.cisco.com/univercd/cc/td/doc/product/lan/cat3750/12240se/scg1/swtrbl.htm#wp1099467

With the flash_init command you should be able to perform some commands on the flash, so probably you can delete the tar file there.

HTH

Mat

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
phillipsfox Wed, 01/02/2008 - 14:43

format flash: helped, i was trying flash[0], flashfs[0], etc... Still have a problem thou...

For some weird reason when i am trying to download the IOS via xmodem i am getting this error message: "no response from remote system." i am sure xmodem is supported as i was uploading an IOS on the same switch earlier... Any ideas? Thanks

christensenbradley Thu, 07/03/2014 - 19:09

format flash: worked for me! Thanks! I hadn't seen that command until now. Been struggling to use xmodem to copy a new ios to a 2900XL, Whew!

phillipsfox Wed, 01/02/2008 - 15:31

OK all fixed, i had to type first:

copy xmodem: flash:iosname.bin and the click send from the transfer menu. Weird the first time i install the ios via xmodem i didnt need to do the first step...

Thanks for your help

Actions

This Discussion