boot: cannot determine first file name on device "flash"

Unanswered Question
Jan 2nd, 2008
User Badges:

I have Cisco 837. By accident the ios image is erased. I guess that the only solution is: using xmodem to upload the ios to the flash. Could someone tell me how to do that? Is it possible to do it by using Hyperterminal and how?


Thanks in advanced.

Peter

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jon Marshall Wed, 01/02/2008 - 05:03
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Hi Peter


Please see the 2 attached links which should guide you through the procedure


1) Xmodem using hyperterm


http://www.cisco.com/en/US/products/hw/routers/ps259/products_tech_note09186a008015bfac.shtml


2) Specific info for 800 series routers


http://www.cisco.com/en/US/docs/routers/access/800/820/software/configuration/guide/rommon.html


Please come back if you need further help.


Jon

rijperwaard Wed, 01/02/2008 - 06:19
User Badges:

Dear Jon,

I have tried with the option 1 just like in the document explained how to restore ios for 1603 router. I got the answer back that the Xmodem doesn't react. I only use xmodem protocol inside Hyper Termninal to try to restore ios. Is it enough or i need a special Xmodem software?


Option2:

Where can i enter the command:

IP_ADDRESS= ip_address etc.

The IOS does not exist anymore. It goes straight to the Rom Monitor by booting.


Thanks,

Peter

Jon Marshall Wed, 01/02/2008 - 06:26
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Peter


You should be able to enter these variables from Rom monitor mode ie.


rommon > IP_ADDRESS=192.168.5.1 (assuming 192.168.5.1 is your tftp server)

etc..


If you can't do this try to use the console section of the second doc


http://www.cisco.com/en/US/docs/routers/access/800/820/software/configuration/guide/rommon.html#wp1020810


Jon

Jon Marshall Thu, 01/03/2008 - 00:17
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Peter


No problem, glad to have helped and thanks for letting me know you have fixed it.


Jon

bvsnarayana03 Wed, 01/02/2008 - 07:09
User Badges:
  • Silver, 250 points or more

tftpdnld is an easier method as compared to xmodem. The second link given by Jon is really helpful.

Actions

This Discussion