Per-packet load sharing

Unanswered Question
Jan 3rd, 2008

I'm trying to use per-packet load sharing on two E1 serial links, but it seems that does not work with FTP.. When I ping I can see the count on the other the two interfaces but when I tryo to FTP, I see the hits on one serial only.. Am I doing something wrong? Or is that a normal behavior?

Thanks in advance..

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Adam Frederick Thu, 01/03/2008 - 07:10

This is normal, IF all the ftp requests are coming from the same source. If you have tons of hosts on the inside sending ftp requests they should be load balancing. but just one in particular, this is normal :)

Ahmede Thu, 01/03/2008 - 07:13

It's per-packet not per-destination load sharing.. So I think it should load share regardless if it's coming from one source or not..

cpubob Thu, 01/03/2008 - 09:34

What is your switching method? CEF, FastSwitch? What command did you use to enable per-packet load-sharing?

Ahmede Thu, 01/03/2008 - 10:26

I have ip cef configured in the globl config.

On the interfaces (S0/0 and S0/1) I have the command

ip load-sharing per-packet

I also have "ip route-cache flow" on both interfaces..

Thanks in advance

cpubob Thu, 01/03/2008 - 10:53

do a "show cef internal" and look for the prefix that covers the ip of the ftp server. Does it say its per-dest or per-packet? Also, just curious, what are you using to confirm that all packets are using only 1 interface?


Ahmede Thu, 01/03/2008 - 11:20

I left the office now.. So I won't be able to do do the show command.. But I use the "show interface" to see the interface output rate, and one interface shows "0" while the other shows soe readings..


This Discussion