Etherchannel Non-adjacent Ports

Unanswered Question
Jan 3rd, 2008
User Badges:

I am trying to create an etherchannel between non adjacent ports on a 6509 running catos and a 4507 running ios. The switches are configured as follows:


Cisco 6509 running CatOS ver 8.4(5)


set trunk 1/1 on dot1q 1-4094

set port channel 1/1 mode on


set trunk 7/1 on dot1q 1-4094

set port channel 7/1 mode on



Catalyst 4500 running IOS ver 12.2(31)SG



interface Port-channel9

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate


interface GigabitEthernet3/12

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

channel-group 9 mode on


interface GigabitEthernet4/12

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

channel-group 9 mode on


I disable all the ports involved, deliver the configuration and when I reenable the ports one line connects and the other line goes errdisabled and no channel is formed. What am I doing wrong?


Thanks in advanced

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jon Marshall Thu, 01/03/2008 - 07:55
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Hi


On your 6500


set port channel 1/1,7/1 mode on


If you do it on 2 separate lines the switch doesn't know you want to channel these together.


HTH


Jon

glen.grant Sat, 01/05/2008 - 07:31
User Badges:
  • Purple, 4500 points or more

Or you set your link to desirable non-silent and let the switch negotiate the channel .


catos

set port channel 1/1,7/1 desirable non-silent



ios


interface range g3/12, G4/12

channel-group 9 mode desirable non-silent

johgill Sat, 01/05/2008 - 09:30
User Badges:
  • Bronze, 100 points or more

What is the errdisable cause? What type of card is module 1 and module 7? If they are different, QoS may complain.


There is a knob to disable checking for this in IOS:

"no mls qos channel-consistency"


CatOS also has a knob, but I don't believe it's available until 8.6(x):

"set port qos channel-consistency "

Pavel Bykov Wed, 01/09/2008 - 00:05
User Badges:
  • Silver, 250 points or more

Also try removing "switchport nonegotiate" command. Turning off DTP does not have any effect since you have trunk mode manually set to ON. Not sure how CatOS functions - maybe it has problems establishing a trunk without DTPs.


Maybe this can be your cue to migrate to Native IOS :)

glen.grant Sat, 01/12/2008 - 11:19
User Badges:
  • Purple, 4500 points or more

there should be no problem with channeling between a catos box and a ios box . Have you looked in the logs , usually it will give you an idea why it err-disabled a port . The other thing to check seeing that you are trunking also is to make sure both ends are using the same native vlan for all ports involved. On the catos side it will just be whatever the ports will fall back to if the channel fails, this is set by the set vlan X slot/port command . On the IOS side you need to add the switchport trunk native vlan X" command . The way it is now it is assuming that everything is in vlan 1 which I don't know if its true or not . What vlan are the ports on the catos side set into ? you also just use the following after verify the native vlan is the same on both sides . Use channel-group X mode desirable non-silent and on the catos side use "set port channel slot/port mode desirable non-silent .

Actions

This Discussion